1
\$\begingroup\$

I'm trying to replicate a simple circuit that I designed in SpiceIV. Here's what it looks like

CircuitLab Schematic 3jv5py

I should be getting ~23 mA of current flowing through this circuit by ohm's law. However, when I measure it using my multimeter if I connect the COM lead to the positive side and the INPUT lead to the negative side I get a result of around -23.5 to -25 mA, which falls within the tolerances of my multimeter.

However, if I switch the leads and put INPUT to positive and COM to negative like I should I get a reading of exactly 13 mA every single time. I cannot for the life of me figure out why the current measurement is correct going one direction, but not correct going the other. I've checked the fuses (~0.8 ohms average when I touched the leads together) and checked my math 100 times.

Can anyone with more experience than me shed some light on this problem? I don't understand it at all. For all intensive purposes SpiceIV shows current in the negative which means my reading is "right", but shouldn't I be seeing the same number going the other way?

EDIT: For clarification I am measuring the current with the multimeter in series with the rest of the circuit.

\$\endgroup\$
1
\$\begingroup\$

if I connect the COM lead to the positive side and the INPUT lead to the negative side I get a result of around -23.5 to -25 mA

Your battery is flat (incapable of supplying more current) and you are measuring across the battery which IS NOT measuring the current through the two resistors at all.

By the time you measure it in the reverse direction it has got flatter. I bet if you tried it back the first way it would read even less.

Try disconnecting the two resistors from the supply and letting the meter "join-up" the two disconnected points and that's how to measure current - current is the flow of electricity through wires and not some arbitrary re-wire that bears no relation to what you are tring to measure.

Get a new battery too.

\$\endgroup\$
  • \$\begingroup\$ Well, the way I was measuring it was I had the multimeter in series with the circuit after the resistors. I mean in reality it shouldn't matter at what point I had it in series, but basically I had INPUT connected to the point just after the resistors, and COM connected to the point just before the ground (in this image). I went ahead and did it your way and it says it's still drawing 13 mA of current. The battery might be the problem. I'll go try to find another 9V lying around (the one im using is only pushing 8.1V now). \$\endgroup\$ – Freeman Jul 21 '13 at 22:30
  • \$\begingroup\$ @Freeman So why didn't you say you did it that way? Another thing - did you measure your battery voltage connected to the circuit or disconnected? \$\endgroup\$ – Andy aka Jul 22 '13 at 6:58
  • \$\begingroup\$ @Andy aka Without the circuit it sits at 8.1V. Even with one resistor (the 367 ohm resistor) it's voltage drop is fine (~7.9-8 volts as expected), and the resistance measurement of the resistor is proper. However, when I measure current across it by connecting the red lead to the battery and black lead to the resistor I still get 0.013A of current draw which is totally wrong. I'm starting to think my fuse might be going out even though the resistance check I mentioned above worked. \$\endgroup\$ – Freeman Jul 22 '13 at 16:17
  • \$\begingroup\$ @Freeman it won't be your fuse but it may be the battery in your meter dude - this may also be causing you to measure the resistance incorrectly. \$\endgroup\$ – Andy aka Jul 22 '13 at 17:01
  • \$\begingroup\$ Turns out my multimeter is broke. Thank you everyone. I'll award credit to the parent post. \$\endgroup\$ – Freeman Jul 25 '13 at 5:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.