2
\$\begingroup\$

I've just received Funduino Mega 2560. This is a Chinese product and should be the exact copy of Arduino.

I am having problems connecting it to my computer and have spent several hours trying to figure it out to no avail.

My operating system is Windows 7 x64 and here are the steps that I tried:

  • Restarting Windows.
  • Pressing Reset button on the device.
  • Switching to other USB ports on my computer.
  • Using different cables (including the one that works with my printer).

None of this helps. The device is not listed in Device Manager and Windows does not produce the sound when connecting plug-and-play device. Because of this, I am unable to get to the point to install the drivers for it.

I have also tried to put the device in DFU mode by shortening RESET and GND next to Mega8U2 chip in order to try to upload a new firmware. The device is not responding.

Here's the video footage when the device is plugged in. Power LED is constantly on and L LED is flashing in a specific pattern.

Can anybody help me on how to get this thing detected by my computer?

\$\endgroup\$
  • 1
    \$\begingroup\$ If there is absolutely no indication in Device Manager (such as of an "unknown device") then the board is either physically faulty or has not been loaded with working firmware. "Should be an exact copy" contains that interesting word, "should"... \$\endgroup\$ – Chris Stratton Sep 7 '13 at 20:08
  • \$\begingroup\$ @ChrisStratton I reckoned mentioning it was a Chinese product would raise suspicion, maybe even rightly so. However, I really didn't have any problems using Chinese electronics thus far, including various Atmel product clones. I have tried to upload a new firmware, but I'm not sure on how to proceed with Mega 2560 board. The description on Arduino website is for Uno and I cannot apply it to Mega 2560. \$\endgroup\$ – Nikola Malešević Sep 7 '13 at 20:43
  • 1
    \$\begingroup\$ Given that it only takes having a pullup resistor on the correct USB data line to get an "unknown device" message, a board that can't even get that minimal aspect right is a really, really bad knockoff. There's lots of import electronics which is fine, but it's a basic lesson from economics that prices fall until some of the shipped product just doesn't work and it's very clear that some of what is for sale these days is in that territory. \$\endgroup\$ – Chris Stratton Sep 7 '13 at 20:47
  • \$\begingroup\$ I had the same problem and I found a page that describes a solution to chinese arduinos using a nonstandard USB chip. requires a specific driver for windows or mac. Look at: instructables.com/id/How-to-fix-bad-Chinese-Arduino-clones \$\endgroup\$ – estephan500 Mar 1 '18 at 8:01
2
\$\begingroup\$

There are many things that could cause the issue. Some of the things to look for are:

1) Try to use a good cable. Some cables have caused USB issues.

2) Some Arduino boards need a solder in the back. There are two pads that should be shorted together. Try to short them and see. These connect GND I believe

\$\endgroup\$
  • \$\begingroup\$ 1) I've already mentioned that I've tried using different cables, so this is not an issue. 2) I'm not sure which pads to solder/connect the resistor between as the pictures on Arduino website are related to Uno, not Mega 2560. Can you give some more details about Mega 2560 board? \$\endgroup\$ – Nikola Malešević Sep 7 '13 at 20:44
  • \$\begingroup\$ Take a look at arduino.cc/en/uploads/Main/ArduinoMega2650Back.jpg You can see two sets of pads. I believe both need to be shorted. Look at the schematic and you'll see ground is a pad next to pin 33 of ATMEGA16U2. This needs to be shorted together. \$\endgroup\$ – Gustavo Litovsky Sep 7 '13 at 22:52
1
\$\begingroup\$

After many hours of trying to find a solution, I've concluded that Mega8U2 chip serving as USB to serial converter is dead.

I could not get it to respond in any way and I ended up using my AVRISP mkII programmer and ISP interface to program Mega2560, while using TX0/RX0 pins for serial communication.

\$\endgroup\$
0
\$\begingroup\$

Here are some suggestions for you to test it. 1.The USB cables you used may be damaged. Please test the cables to see whether the cables work. 2.Change other USB ports to have a try. Sometimes, the problem is caused by the power supply which is not enough. Pls make sure the input voltage is 5V if it is connected with USB port. If it is connected with power supply directly, it is necessary to provide 9V input voltage. Hope it will be helpful.

\$\endgroup\$
  • \$\begingroup\$ Thanks for the answer, but I've already solved the issue. \$\endgroup\$ – Nikola Malešević Aug 7 '14 at 9:53
  • 1
    \$\begingroup\$ Why all the down votes? Just because an answer is selected, are we not allowed to post additional answers? In addition, each of the tips above were reasonably valid attempting to determine if the device or cable was working. \$\endgroup\$ – Samee87 May 20 '15 at 19:22

protected by Community May 20 '15 at 19:36

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.