2
\$\begingroup\$

I have tried EVERYTHING to make this work, including replacing the board.

I have an arduino fio

I am attempting to upload a sketch to it (just a blink to validate it works) with an FTDI to USB cable

I am using Arduino 1.5 BETA and I also tried Arduino 1.0.5 Neither of which worked and resulted in the same error.

I attempted to use a different comp with a fresh install that resulted in the same error.

I updated my FTDI driver to 2.0.8.30 still the same error

I dismantled the FTDI wire and re-soldered it to new wires to verify it wasn't a bad connection.

I attempted setting the baud rate in device manager to 9600,57600, and 115200

I tried pressing the reset button as I uploaded the sketch

I tried changing COMS

I tried plugging an Arduino Uno in, validating that it works no problem. Then I plugged the fio back in. Got the same error again same error.

This is the second board I have gotten that does this. It's not the board. What the hell is wrong with this software. I shouldn't have to work this hard to upload a freaking sketch.

IDE output

avrdude: Version 5.11, compiled on Sep  2 2011 at 19:38:36
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2009 Joerg Wunsch

         System wide configuration file is "C:\Program Files (x86)\Arduino/hardware/tools/avr/etc/avrdude.conf"

         Using Port                    : COM4
         Using Programmer              : arduino
         Overriding Baud Rate          : 57600
avrdude: Send: 0 [30]   [20] 
avrdude: Send: 0 [30]   [20] 
avrdude: Send: 0 [30]   [20] 
avrdude: Recv: 
avrdude: stk500_getsync(): not in sync: resp=0x00

avrdude done.  Thank you.

And yes, I have tried restarting both the IDE and the computer(s).

\$\endgroup\$
  • \$\begingroup\$ Has it worked in the past? \$\endgroup\$ – JYelton Oct 8 '13 at 3:41
  • \$\begingroup\$ Yes, which is the most irritating part. When I first got it (about a week ago) I uploaded a blink sketch to it and it worked. 1 week has gone and it has been sitting on my desk untouched. NOTHING has changed \$\endgroup\$ – Anthony Russell Oct 8 '13 at 3:41
  • \$\begingroup\$ Hmm. Check out this page and see if any of the various posts there are helpful: forum.arduino.cc/index.php?topic=28223.0 \$\endgroup\$ – JYelton Oct 8 '13 at 3:54
  • \$\begingroup\$ That is where I got many of the solutions I tried above \$\endgroup\$ – Anthony Russell Oct 8 '13 at 4:03
  • 1
    \$\begingroup\$ @OlinLathrop Olin, in this case I defend his position. I'm pretty sure that "base" and "bit" meant something else before electronics, yet no one complains here. These terms are specific to a product, so it's correct to use them in that context. \$\endgroup\$ – clabacchio Nov 8 '13 at 16:31
3
\$\begingroup\$

So I went out to microcenter today and bought ANOTHER new arduino fio. I also bought a usb to FTDI breakout board instead of a cable.

For ish and giggles I attempted to load a sketch onto my old arduino with the new breakout board. Worked instantly.

5 Hours wasted and lesson learned. Try a new cable if you get this error.

\$\endgroup\$
1
\$\begingroup\$

I had the same issue in windows 7.

I had to:

  1. open the FTDI USB to Serial device in the device manager of windows.
  2. Open the properties dialog and access the advanced options of the FTDI device.
  3. Enable the option "Set Rts on close"

The issue was than the RTS line that is used to reset the AVR and thus call the bootloader was never used and thus the bootloader was never called....

\$\endgroup\$
0
\$\begingroup\$

While uploding the codes from Arduino IDE on your computer, please pull out Arduino card's RX pin 0. You will get success code uploading. Plug out RX pin and try.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.