2
\$\begingroup\$

I am making a custom footprint for a component. However if I use the component then Eagle doesn't auto route any connections to that component. Does anyone have any ideas?

enter image description here

\$\endgroup\$
  • \$\begingroup\$ More information needed. When you created the package did you use proper pads and name them? When you created the device did you link these to the corresponding pins on the symbol? Does ratsnest work properly and highlight missing connections if you manually route? \$\endgroup\$ – David Oct 17 '13 at 7:27
  • \$\begingroup\$ I didnt use any pads. It is an ic. So I used a top copper layer and a tplace on top of it much like the tqfp 44 example in atmel.lbr. Rats nest works correctly \$\endgroup\$ – Developer Android Oct 17 '13 at 7:30
  • 3
    \$\begingroup\$ Enable 'show grid' and check whether there are grid points on your pads. If not, the autorouter can't reach them. Solution: select a finer grid. \$\endgroup\$ – Wouter van Ooijen Oct 17 '13 at 8:16
  • \$\begingroup\$ I will try that out. \$\endgroup\$ – Developer Android Oct 17 '13 at 8:39
  • 1
    \$\begingroup\$ Its the routing grid which I have to change. It works now \$\endgroup\$ – Developer Android Oct 17 '13 at 9:54
2
\$\begingroup\$

Enable 'show grid' and check whether there are grid points on your pads. If not, the autorouter can't reach them. Solution: select a finer (routing!) grid.

\$\endgroup\$
  • \$\begingroup\$ I don't think the grid points on the board drawing matter, just the grid size you define in the autoroute menu. \$\endgroup\$ – Scott Seidman Oct 17 '13 at 13:55
  • 1
    \$\begingroup\$ Yes, the OP discovered that it was the routing grid and not the drawing grid that was the problem. Unfortunately, the question still appears as though it has not been successfully answered. \$\endgroup\$ – Joe Hass Oct 17 '13 at 14:09
0
\$\begingroup\$

I'm willing to bet that you put the outline for the component into the Dimension layer, which is really only for the board outline. Put it in the tDoc layer, or something like that.

I did the exact same thing, once upon a time, and it was very frustrating.

\$\endgroup\$
  • 1
    \$\begingroup\$ It was the routing grid...see the full list of comments to the original question. \$\endgroup\$ – Joe Hass Oct 17 '13 at 14:10
  • 1
    \$\begingroup\$ thx Scott Seidman. Had exactly the same problem and putting my parts outline on any other layer as "Outline" solved it. \$\endgroup\$ – user110268 May 16 '16 at 15:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.