I just got this SIM908 dev board, and I'm trying to get it working. However, it keeps telling me "SIM not inserted":

+CME ERROR: SIM not inserted

which of course causes other operations to fail:

+COPS: (1,"AT&T","AT&T","310410"),,(0,1,4),(0,1,2)
+CME ERROR: operation not allowed

I was trying to use the SIM card from my smartphone (StraightTalk on AT&T), and I also tried an unprovisioned AT&T SIM just to see if it was detected.

Could the problem be that the SIM card has the wrong application on it? Should USIM be backwards compatible with a 2G module?

Also, I don't know if this is related, but I noticed that just after power-up, SIM_VDD oscillates briefly at about 2MHz. I think that might be a normal part of the voltage detection process, but I'm not sure.

What should I need to get this working?


2 Answers 2


Okay, I was heading down dead ends there. The vendor just confirmed that there is a fault with the SIM card holder on the board.


A lot of GSM devices have a high inrush current as they first start. When used in a mobile device that's normally handled by the battery well. Some switching regulators don't cope with the peak demands well and it's worth keeping the power leads as short as possible to minimize voltage drop.

That particular module shows a peak current of 2A and VBAT range of 3.2 - 4.8V. If it's possible I'd recommend running at 4V to give some extra headroom for voltage dips. Otherwise you could have a look at using reservoir caps to handle the peaks.

In fact I just found a EDA board post that says a similiar problem was solved by adding two big capacitors, one between VBAT and GND and one between VCC and GND of the SIM card holder. Personally I've never had to use a capacitor across the SIM card power rails but it might be worth a try. If you haven't spotted it already it's also worth taking a look at the SIM908 Hardware Design Guide (it's a Microsoft Word .DOC file).

I can't answer the part about AT&T SIM cards because I'm outside the United States, but locally I've never had a problem using new SIM cards with 2G devices and they shouldn't need an application of any sort loaded.

One additional thing is that if you have access to a scope it'd be worth connecting it to the power rails as close as possible to the module with a negative going trigger at about 3.25V. That way if it does solve the problem you can confirm that it's not still on the edge of "just working". It's probably a worthwhile test regardless.

  • \$\begingroup\$ The board is USB-powered and regulated to about 3.6v all on the board, so I don't really have any control over that. (I could, I suppose, power it from a bench PSU and use a Bus Pirate on the UART port.) Anyway, here's what I'm seeing. Not quite sure what to make of it: i.imgur.com/GOQgUSm.png That's on a 3.2v trigger, although it seems to be dipping as low as 3.08v at 100KHz. The CLI never indicates that the device has actually reset, though, so I don't know. Can you even get more than 500mA out of USB? \$\endgroup\$
    – Isvara
    Nov 6, 2013 at 7:48
  • 1
    \$\begingroup\$ @Derecho, most GSM modules I've seen don't seem to tolerate even really short dips well, I assume to stop them transmitting junk that might interfere with the network. They often don't reboot just don't try to connect. Normally 500mA should be OK with large caps because the average is lower, it's interesting though for a commercial product that it hasn't been taken into account although some dev boards are better than others. I'd still try a large cap (1000uF+) and see how you go or try the bus pirate / PSU. \$\endgroup\$
    – PeterJ
    Nov 6, 2013 at 7:58
  • \$\begingroup\$ There is a big-ass cap on there. 477. (That's 470uF, right?) I'll try it with a bigger PSU tomorrow. \$\endgroup\$
    – Isvara
    Nov 6, 2013 at 8:17
  • 1
    \$\begingroup\$ @Derecho, yes that's right on the cap. As well as the PSU probably also worth trying a different USB cable and PC / laptop if you have one - maybe you have a dodgy connector / cable along the way. \$\endgroup\$
    – PeterJ
    Nov 6, 2013 at 8:23
  • \$\begingroup\$ Actually, I just saw that he does have a video of him powering it from a PC USB port and using it to make a call, so that must be possible. Switching to a USB3.0 port (900mA vs 500mA) didn't help. I'll try on a Mac or something first. \$\endgroup\$
    – Isvara
    Nov 6, 2013 at 8:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.