I am not seeing anything on a port in realterm though it is properly sending the data through the port. Anyone run into a similar situation? What am I doing wrong?

I am using a C8051F120 developers kit, a RS232 to USB converter, and realterm. On the 8051 I have an example program running that mirrors input received on the input. I have seen the data received then sent on the DB-9 end of the converter using an o-scope, but I haven't seen anything show up on realterm. The converter was working for a different project so it should be good.

  • \$\begingroup\$ For an initial test you could try shorting pins 2 & 3 on the RS232-USB adapter to make sure things echo back (and stop when you remove the wire). \$\endgroup\$ – PeterJ Nov 10 '13 at 23:28
  • \$\begingroup\$ I tried that too not knowing if it'd work, but still didn't get anything in realterm. \$\endgroup\$ – Jason Nov 10 '13 at 23:50
  • \$\begingroup\$ That makes it sound like it's a USB adapter problem unless hardware flow control is enabled in RealTerm. Maybe check under device manager the COM port number hasn't changed, maybe force it to a new number and try a few things like that. \$\endgroup\$ – PeterJ Nov 10 '13 at 23:52
  • \$\begingroup\$ It looks like you have to reset your computer after plugging in a RS232 to USB converter and installing the driver for the first time. BTW, Thanks for your help Peter! \$\endgroup\$ – Jason Nov 11 '13 at 0:05
  • \$\begingroup\$ Add your comment as an answer to your own question. It might be useful to other people with similar problems. \$\endgroup\$ – mjh2007 Nov 11 '13 at 15:44

So the answer is to reset your computer because the RS232 to USB converter's driver automatically installed needs a restart even though there was no prompt for one before it can be used.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.