4
\$\begingroup\$

I've created a couple of parts and stored them in a library called trackuino.lbr. I followed sparkfun's tutorial. I am able to add the part to my schematic but when I want to edit the part, I right click on the symbol and choose "Open Symbol" or "Open Device" and I get the following error: enter image description here

Thoughts?

EDIT:
1. I am able to insert the part with the "Add a part" tool
2. I have tried moving my library from my eagle folder to another directory and adding that directory to the library path. Same issue here, I can add the part but right clicking and choosing "open device" or "Open Symbol" results in the above error.
3. I'm not sure what the "or export drawing libraries first!" part of the error message means?
4. I am running eagle 6.5.0 Light on Linux Lint 15 like Ubuntu 13.04

\$\endgroup\$
  • \$\begingroup\$ Welcome to Electrical Engineering StackExchange. In this case it appears that the error message is self explanatory. Please be specific about what is unclear to you and what you have tried to fix the problem. Try to formulate a better question. You should also tell us about the operating system you are using and the version of Eagle that is giving the error. \$\endgroup\$ – Joe Hass Dec 1 '13 at 3:26
  • \$\begingroup\$ Hey @JoeHass I've added the requested information. Sorry about the vagueness. Have you seen this particular error before? \$\endgroup\$ – TechplexEngineer Dec 1 '13 at 3:40
3
\$\begingroup\$

Had the same problem. In my case the problem was that I had a sub-dir under my library path containing the libraries in use and the library path setup in Eagle didn't include sub-directories.

By adding all of my sub-directories one by one in the library path the open device feature started to work...

Good luck.

\$\endgroup\$
  • \$\begingroup\$ Perfect! This solved is for me, as this problem still exists even now, in Eagle 7.7.0. This is clearly a bug. If anyone wants to report it to Eagle please do... \$\endgroup\$ – Gabriel Staples Nov 6 '16 at 20:00
2
\$\begingroup\$

It's possible that your library is in the right path, but it's not enabled.

enter image description here

To enable a library, click the gray circle next to it. It should become green.

\$\endgroup\$
  • 1
    \$\begingroup\$ Hey Nick, when eagle starts up my library is not enabled. I have to enable it every time. Even when the library is enabled, I still get the above error message when I try to open my custom part. \$\endgroup\$ – TechplexEngineer Dec 1 '13 at 13:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.