Can someone tell me how to add PSPICE Model in Orcad Capture and PSPICE simulator.

] have downloaded LM239 PSPICE model from texas instrument site, the file they are providing is "LM239.5_1".

While running the simulation I had an error "ERROR(ORPSIM-15108): Subcircuit LM741/NS used by X_U5 is undefined" and have no idea how to resolve it.

  • 1
    \$\begingroup\$ You should try to look at the PSPICE user manual, it probably has the instructions to do that. \$\endgroup\$
    – clabacchio
    Commented Dec 6, 2013 at 7:24
  • \$\begingroup\$ PSPICE user manual is of no use, had checked that. now by going through some tutorial provided by Texas Instru, got to know how to create a model but now the problem is i am getting this error while running the simulation and have no idea how to resolve "ERROR(ORPSIM-15108): Subcircuit LM741/NS used by X_U5 is undefined" \$\endgroup\$
    – Atmega32
    Commented Dec 6, 2013 at 8:26
  • 1
    \$\begingroup\$ You should update your question with the contents of your comment. \$\endgroup\$ Commented Dec 6, 2013 at 11:27

3 Answers 3


The answer below is how to properly import a PSpice model (usually generated in a third-party software) into Orcad Capture and PSpice so that both the schematic editor and the simulator work without errors.

Firstly, the model must be imported into Orcad Capture (so that a new component and a new library .olb is created. Secondly, the model must be properly "fed" to PSpice.

Step 1. Creation of Orcad's component library (.olb file)

  • Open Orcad Capture -> File -> Import -> PSpice -> OK

enter image description here

a) Field Open: path to the PSpice model
b) Field Save as: path to an Orcad library to be created with a new component. Extension must be .opj
c) Field Schematic Configuration File: leave it as suggested

Step 2. Setting up PSpice simulator

  • Copy and paste your model file (e.g. Model.mod).
  • Rename the file from Model.mod to Model.lib. This is done, because PSpice works only with .lib extension.
  • Open Orcad Capture, PSpice -> New Simulation Profile -> Enter any name for the profile (e.g. tran1) -> In an opened window go to "Configuration files" tab -> Library category

enter image description here

  • Enter the path to Model.lib in the Filename field -> Press Add to Design button
  • Make sure that the file {Orcad installation directory}\tools\pspice\library\nom.lib is also added to the Configured Files as a Global
  • Make sure that in the Library Path there is a correct path to the PSpice main library (see the picture above as an example of a proper path).

Final comments
a) Wrt the error you mentioned "ERROR(ORPSIM-15108): Subcircuit LM741/NS used by X_U5 is undefined", this is caused by improper setting of PSpice simulation profile (either improper path to the Model.lib or main Library Path).
b) Overall, the trick is that import of a PSpice model is done twice: once in Orcad Capture and once in PSpice (would have been better if done automatically by the program).
c) Of course, to add the component in Capture, one needs to add the library (Model.olb) in a Place Part subwindow.
d) Not sure, but likely names of the files Model.lib and Model.olb must be the same, so that PSpice knows what Spice model to use.


Which version of PSpice do you use ? Is it PSpice Student or the Orcad version ?

If it's the Orcad version check the Orcad help, which is very good. If you use Pspice student, you can't add a model, you're only allowed to use the default ones.

Usually, Spice model are in plain text so you can edit the model to adapt it in case of error. Also you can change the file extension to have a .lib or another to fit the Spice requirements.

Your error is : "ERROR(ORPSIM-15108): Subcircuit LM741/NS used by X_U5 is undefined", but in the LM239 spice model provided there is no reference to a LM741 model, only to transistors and diode. So this is the LM741 model which is in fault and not the LM239.

Sometimes you need to edit the provided model to fit the spice simulation software, I remember the LM741 when I used it on LTspice, I had to adapt it, maybe you need to.

  • \$\begingroup\$ i have downloaded LM741 model from TI website and created the model for it. i was following this tutorial ti.com/lit/an/sloa070/sloa070.pdf i need to use both LM239 and LM741 but at the error which i have mentioned in the comment of last post was for LM741. this is what i have done, downloaded LM741 PSPice model from ti, changed the file extension to .lib, created model by importing the .lib file using model editor, now put both the .olb and .lib file in the Pspice/library folder, am i missing something \$\endgroup\$
    – Atmega32
    Commented Dec 6, 2013 at 19:25
  • \$\begingroup\$ i am using OrCad version 16.6 \$\endgroup\$
    – Atmega32
    Commented Dec 6, 2013 at 19:30

Here is the solution for OrCAD PSpice users: Whenever you download PSpice model, you get two files (.lib and .olb). Follow the steps from following image (taking power schotkky as example).


If you still get error: After step 12, choose the option "add in profile" instead of "add as Global". It will surely work as it did for me.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.