0
\$\begingroup\$

So I've just received my first bench power supply and she seems like not working. But As it's my first I'm perhaps doing something wrong.

  • First test, I go to continuous voltage, set it to 0V. Put the negative probe of my multimeter in the ground output and the positive to the +V output. Set the multimeter to 20V DC resolution . Start to increase the voltage on the power supply from 0V to 15V (max). My multimeter is like going crazy from -1.5V to +1.5V with any loads (from 0.1V to 15V same result) But the screen on the power supply looks like displaying the correct value.
  • Second one, set it up to continuous current, can't change the value, always display 0A, sometimes voltage change a bit without any wires attached to the output. Usually when the current wheel is at 100%, then I can read 0A and around 1V to 1.2V.

So, am I doing something wrong or does it just doesn't work ? (In that cas have to return it asap)

EDIT : Additional tests :

  • I've checked the fuse, seems ok (for me shouldn't even turn on without but who knows).
  • I've tested with another multimeter and same result.
  • I've try do plug a PC fan on it 12V, 150mA, in CC or CV doesn't work but work when plugged on a 9V battery so the fan is ok.
\$\endgroup\$
  • \$\begingroup\$ Put a 10K resistor (or similar) across the outputs and try to measure the voltage again. Let us know what happens. \$\endgroup\$ – geometrikal Dec 13 '13 at 4:54
  • \$\begingroup\$ There maybe more than one fuse. Make sure to remove the fuse before testing continuity, check your multimeter is on DC, not AC, and don't try to measure current across the output without some kind of load in series. Check your fuse in your multimeter. (Sorry if these are obvious) \$\endgroup\$ – geometrikal Dec 13 '13 at 4:59
  • \$\begingroup\$ So, with a 10K resistor and 5V output, 0V measured on the multimeter. Yes the multimeter is on DC and he's working with other power supply or battery and I've test with another multimeter and same result so I don't think the problem comes from him. And with a 10Kohm resistor 0V read on both multimeters... And to be sure I've tested after the resistance, 10K displayed on the multimeter and with a 9V load from a battery, voltage and current readings are ok on the multimeter. \$\endgroup\$ – Emmanuel Istace Dec 13 '13 at 5:09
  • \$\begingroup\$ Just to know, why can't I just measure at outputs without load ? \$\endgroup\$ – Emmanuel Istace Dec 13 '13 at 5:09
  • \$\begingroup\$ If you use multimeter in current mode and read across output with no load it is like putting a short across it and will blow the fuse if the multimeter fuse doesn't blow first. \$\endgroup\$ – geometrikal Dec 13 '13 at 5:11
3
\$\begingroup\$

The ground terminal is almost certainly not connected to the power supply output terminals. To measure the output voltage of the power supply, you must turn the current limit knob up somewhat, and measure the voltage between the black and red output jacks.

With the current control turned to minimum, the supply probably won't output any voltage, as the current is limited to zero.

To test the current limit, set your meter to a current scale, and connect to the red and black terminals (again, the yellow ground terminal is not connected to the power supply output - it is just there to give you convenient access to the AC power ground). Start with the current control fully counterclockwise (minimum), turn the voltage pots up somewhat, then slowly turn the current limit knob clockwise - you should see increasing current on your meter, which should match the current indication on the power supply.

\$\endgroup\$
  • \$\begingroup\$ DAMN ! I was doing it totally wrong !, I was testing with the yellow as ground. I was thinking that the black terminal indicated as minus was there to get a minus DC voltage (like the power supply is setted up to 5V, so +5V on the red and -5V on the black)... damn... You saved my day ! \$\endgroup\$ – Emmanuel Istace Dec 13 '13 at 16:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.