1
\$\begingroup\$

I am trying to use gschem/gnetlist/ngspice to do some circuit simulations. I have a subcircuit schematic and have created a symbol. I am able to add the symbol into the higher level schematic in gschem but when run gnetlist I get the following error:

WARNING: Found a placeholder/missing component, are you missing a symbol file? [<symbol file name>]

The device does not appear on the output netlist. The symbol file is in a subdirectory called "symbols" and in my ~/.gEDA/gafrc I have the line

(component-library "./symbols" "Local Symbols")

as per advice on the gnetlist mailing list but for some reason it still cannot find it, though gschem finds and uses the symbol without a problem. I've tried many things but I cannot get gnetlist to find the symbol. I've scoured the Internet for an answer to no avail and I posted here because there is apparently no simple way to post the question on the gEDA mailing lists. Anyone have an idea what is going on here?

\$\endgroup\$
1
\$\begingroup\$

I found the answer to this by looking at the gnetlist log files in ~/.gEDA/logs. The problem was that I had some things in my gafrc file that were valid for gschem but were not for gnetlist. As a result gnetlist was apparently not loading the rest of the file where the component-library command was. Once I removed the gschem-only commands, gnetlist was able to load the symbol and complete without any warnings. The subcircuit components were then in the output netlist as expected.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.