I have a number of W2K systems that we are trying to use to program the new Arduino Uno and Mega devices. These boards now come with a USB connection, an upgrade from the prior FTDI. I'm not able to download the Arduino code into the board from a W2K system

The supplied drivers are *.inf files that modify the standard USB driver that comes with Windows (in this case W2K)

I go through the process of setting the port, setting the device and doing the download. The download fails, and the apparent error is that the PC can not communicate with the board. I've checked the port, adjusted the baud rates, etc. I've even moved the port number from a high port number (ie COM12) to a lower port (COM2) without any success. I do see activity on the rec/xmt lights on the Arduino board, so some type of data is being sent and received.

I'm looking for:
Someone who has been able to download files from W2K to the Arduino
A way to shim inside the USB driver to be able to watch the traffic going up and down to the board so I can continue to debug this.
Some general tips for things to look at in the .inf file that need to be set/not set to make it work on W2K.

I know the boards work I've used them on a different set of XP systems. So I know to some extent the install is good and that most of what I have works.

Full dumps can be found on the Arduino forum.
This is the information produced by the AVRDude program while it's trying to download the code.

It was suggested at stackoverflow that this be posted here.

  • \$\begingroup\$ have you tried using the reset button before you sending your code to the board? and have you looked at reinstalling the FTDI driver or updating it? \$\endgroup\$
    – jsolarski
    Commented Jan 26, 2011 at 13:21
  • 1
    \$\begingroup\$ Yes, no positive result. These boards don't use FTDI, the ATMega 8U2 is used for USB-to-serial communications. The driver is a .inf file that modifies the standard USB serial driver. \$\endgroup\$
    – Astro
    Commented Jan 26, 2011 at 13:45
  • 1
    \$\begingroup\$ It is probably related to the USBSER.SYS driver in Win2K. A preliminary search on Google found several results where people have experienced problems with the Win2K version of the driver vs. the XP version. Some people have mentioned using the XP version of the driver on Win2K, but the information is spotty. \$\endgroup\$ Commented Jan 26, 2011 at 16:01
  • \$\begingroup\$ I'm not able to get the XP version to work on W2K. I go into safemode, move the XP usbser.sys into the /dllcache directory and into the /driver directory. When I reboot the windows critical file manager has put the W2K version back. I've googled how to do it, but there is no real guide. \$\endgroup\$
    – Astro
    Commented Feb 7, 2011 at 14:34
  • \$\begingroup\$ Why the heck are you still using windows 2000? \$\endgroup\$ Commented Apr 26, 2012 at 22:22

2 Answers 2


Looking at the dump, it says 'Overriding Baud Rate : 115200'. look into your /hardware/arduino/boards.txt file, and try changing it to 57600.





I had a similar problem (on ubuntu) with my UNO board and a new Atmega328p-pu chip I ordered. It didn't want to upload.

The Atmega328p-pu datasheet specifies that its transfer rate is 57600 baud, but the boardx.txt file was set to 115200 baud. It worked as soon as I set it back to 57600.

  • \$\begingroup\$ Thanks, I tried 57600 and it did not make a difference. If I run realterm on the machine I can see characters go down to the Uno. If I jumper the connection from pin 1 to pin 0 I don't see the echo from the Uno. \$\endgroup\$
    – Astro
    Commented Feb 7, 2011 at 14:32

I have the same problem. I just found a step by step solution changing the USB driver to the XP version. Here is the link: Programming An Uno Under Windows 2000.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.