2
\$\begingroup\$

I have a clone of Arduino which is GizDuino ATMEGA644 and a Universal Keyboard and Display Terminal (e-term). With this imagesenter image description here

I connected the terminal to the microcontroller, after connecting that I tried to upload a sample program under the "LiquidCrystal" category "Hello world". After successfully uploading the program there was no display on the LCD and I also tried checking it to the serial monitor but it don't have the output too. I'm confused in searching what is the problem, I checked the com port and the selected board but there was no problem. can someone help me?

\$\endgroup\$
  • \$\begingroup\$ Was the sample program written for the specific boards? \$\endgroup\$ – alexan_e Jan 9 '14 at 9:27
  • \$\begingroup\$ @alexan_e I uploaded a sample program which can you see in the arduino 1.0.5. A program under the "LiquidCrystal" category \$\endgroup\$ – NewInEverything Jan 9 '14 at 9:29
  • 1
    \$\begingroup\$ Have you selected GizDuino ATMEGA644 as your board in the Arduino boards menu? \$\endgroup\$ – alexan_e Jan 9 '14 at 9:57
  • \$\begingroup\$ Yes I did, I also checked its com port, it's all ok. \$\endgroup\$ – NewInEverything Jan 9 '14 at 10:01
1
\$\begingroup\$

Parallel vs Serial

When you use LiquidCrystal library you have to tell it the GPIO pins that are used to connect to the display. There are two control connections and a 4-wire parallel data connection.

However, the LCD display on your E-term communicates using a TTL-level serial link, not a parallel GPIO link.

Easy to use LCD display and Keyboard decoder combo that integrates with any controller circuit. The LCD can display up to 80 alphanumeric characters at a time in 4 lines x 20 characters arrangement. The keypad consists of a 0-9 numeric keypad and 6 user defined function keys. Communication with the host is via serial port operating at TTL level.

You can't drive your E-term using LiquidCrystal library.

Your diagram is small but it shows TX and RX connected to the Eterm, not a set of 6 GPIO pins.

Note that, in most Arduinos the same TX and RX are used for USB communication with the Arduino IDE software on your PC. To transfer compiled sketches to the GizDuino+. So you may need to switch the RX connection between USB and E-term somehow. AT least disconnect RX from your E-Term when using the IDE to program the GizDuino+.

Power

The E-term description says

Power Input: 8-12V
Display : 4x40 LCD
Input device: 0-9 numeric keypad and 6 user defined function keys

Note that it requires a minimum of 8V. Your diagram shows the E-term Vin connected to the GizDuino+ Vin pin. This wont't supply 8V if you are powering your Gizduino from the USB 5V supply. You need to power the combination from an off-board supply of between 8 and 12 volts (e.g. 9V 1A wall-wart or battery)

Conclusions

I'd

  • Ensure the E-term has it's 8-12 V supply connected to a supply of that voltage.
  • Set the serial comms speed to the data rate in the E-term manual.
  • use Serial.print() not LiquidCrystal.print() etc.

e.g.

void setup()
{
  // initialize the serial communication:
  Serial.begin(9600);
  // send text to E-Term
  Serial.println("Hello E-term...");
}
void loop()                       // run over and over again
{
   Serial.print("*");
   delay(1000);
}
\$\endgroup\$
  • \$\begingroup\$ My e-term is connected to a 8-12V supply. Is there a library that uses TTL-level serial instead of GPIO? \$\endgroup\$ – NewInEverything Jan 9 '14 at 10:30
  • \$\begingroup\$ @NewInEverything: Use the Serial library (see above). \$\endgroup\$ – RedGrittyBrick Jan 9 '14 at 10:31
  • \$\begingroup\$ I cant see where i can download the Serial library. \$\endgroup\$ – NewInEverything Jan 9 '14 at 10:45
  • \$\begingroup\$ @New: There is no need to download it, it's a standard part of the Arduino IDE software. \$\endgroup\$ – RedGrittyBrick Jan 9 '14 at 10:45
  • \$\begingroup\$ Oh, I'm sorry.I tried your example but there is no output even in the serial monitor. My microcontroller have a 8-12v supply pin so there is no question to the supply but there is still no output. \$\endgroup\$ – NewInEverything Jan 9 '14 at 10:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.