-1
\$\begingroup\$

schematic

simulate this circuit – Schematic created using CircuitLab

Parallel port ideally gives TTL logic 0(low) and 5V (high). But my port gives 3.3V high. I have designed my controlcircuit assuming the high to be 5V? Is there a way to regulate the 3.3V to 5.0V so that I can still use the existing control circuit?

thanks in advance

\$\endgroup\$
  • 4
    \$\begingroup\$ More information needed. A circuit diagram is about essential. | Using a pullup resistor in the driven inputs to 5V may work. Also may do damage - show us the circuit diagram please. \$\endgroup\$ – Russell McMahon Jan 23 '14 at 7:11
  • \$\begingroup\$ Assuming your circuit has an external power source you can easily use a transistor or mosfet as a level translator. \$\endgroup\$ – alexan_e Jan 23 '14 at 9:53
  • 3
    \$\begingroup\$ Two obvious answers: 1 - Fix the design. 2 - Read the datasheet before doing the design next time. \$\endgroup\$ – Olin Lathrop Jan 23 '14 at 13:09
  • \$\begingroup\$ Sorry for not posting the schematic previously. I have edited my question to include it. The circuit simulator gives 2.0 A for 5V high at the parallel port and with $V_{BE}$ drops of nearly 0.6 and 1.2 for TIP41 and TIP122, I am expecting 1.5 A. \$\endgroup\$ – baalkikhaal Jan 23 '14 at 18:42
2
\$\begingroup\$

TTL logic should accept anything over 2.0 volts as a high. A TTL output high is only guaranteed to be above 2.4 volts, according to an ancient TI databook.

You shoud therefore design your inputs to accept anything over 2.0 volts as high, and anything under 0.8 volts as low.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.