0
\$\begingroup\$

To start off I'm pretty new and have never used a LED strip before. I bought a meter of RGB LEDs off of ebay. The strip is based on the newer LPD8806 chip. I downloaded and tried to run the strandtest from adafruit's library. I can't seem to get it working correctly though. Any suggestions would be helpful.

Strip Wiring
Black  - Ground
Green  - Pin 3 On Arduino
Red    - 5v from ATX PSU
Blue   - Pin 2 On Arduino

Arduino Uno Wiring
gnd    - Shared Ground

enter image description here
enter image description here

\$\endgroup\$
1
\$\begingroup\$

Strip Wiring
Black - Ground
Green - Pin 3 On Arduino
Red - 5v from ATX PSU
Blue - Pin 2 On Arduino

Your connection doesn't seem to be correct, I think you are following a wrong pinout.

Based on the designators of your provided image (viewed at the right side pads which are the same as the left side pads)

enter image description here

The pinout is:

Black: Data  
Green: Clock  
Red: 5v  
Blue: Ground
| improve this answer | |
\$\endgroup\$
0
\$\begingroup\$

Do you have the ground from the PSU connected to the ground of the arduino? If not, the strip will not work.

With a single meter of LPD 8806 you can run strandtest with the strip powered just by the arduino. I recommend getting that working before adding an external power supply.

| improve this answer | |
\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.