Questions tagged [debugging]

The process of identifying, quantifying, and correcting errors in the operation of a system

76 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
2
votes
1answer
129 views

Sending commands to semihosting in VSCode + cortex-debug

I'm trying to move away from doing my firmware development in Eclipse GNU MCU for several reasons, mostly related to project maintainability (much easier to integrate CMake such that there is only one ...
2
votes
1answer
328 views

W5500 with POE functionality Link status ON with nothing plugged in?

I am working on a design that uses a W5500 for networking. I followed a reference schematic and believe all my connections are correct, however I am facing issues with the network connectivity. ...
2
votes
1answer
102 views

Debugging PIC16F886 with PICkit4

MCU: Pic16F886 Programmer: PICkit4 IDE: MPLAB X IDE v5.40 Assembler: pic-as v2.30 (xc8) Circuit: A LED with 270 ohm resistor on RA0. 3,3k ohm resistor pullup resistor on MCLRE. Vdd on pin 20. ...
2
votes
0answers
169 views

Best device to read/write memory on multiple architectures?

tl;dr: I want to read/write memory from a PIC MCU and an EEPROM, both of which are soldered to an experiment board. I would like to explore programming and debugging ARM in the near future. Which ...
2
votes
0answers
177 views

Debug Netduino without .NET Micro Framework

I have a Netduino, but I am programming it using the GNU ARM toolchain in Eclipse and VisualGDB so the .NET Micro Framework (NETMF) firmware has been removed. Is there a way I can set it up for ...
2
votes
0answers
503 views

Atmel Studio JTAG Debugger Behaviour

The qeustion: I would like to know what is different about the way JTAG treats the "step over" and "step into" commands. Background: I am trying to set a GPNVM bit on a SAM3N (ARM Cortex M3) chip ...
1
vote
0answers
57 views

TPS63050 Switcher Power Good Signal

I've got a board where I'm using the TI TPS63050 switching regulator. I've recently discovered that if I put a bit more load on the output, I get some spurious event on the PG (power good) open-drain ...
1
vote
0answers
52 views

What Is the Best Way to Debug an AVR Microcontroller Using the Command Line?

My AVR programming method is usually as follows: compile the source code with avr-gcc: ...
1
vote
0answers
25 views

Connected my audio input to two music systems by splitting the input, but the one with subwoofer produces continuous 100Hz hum

I have 10 year old Creative 2.1 audio system that has fairly capable subwoofer, and combined its input with a TPA3110 2x15W stereo amplifier module (for better treble). When both systems are powered ...
1
vote
0answers
48 views

Is there a “universal” JTAG controller peripheral?

JTAG can be used to read/write data from/to FPGAs. I want to know if there is any device with an interpreter that can be used with user written STAPL files. Basically the peripheral shall wiggle the ...
1
vote
0answers
52 views

can someone help me build a usb jig to force android device into recovery

Years ago i bricked a phone trying to install a ROM not designed for that phone. As a result the phone went into a bootloop and would not go into recovery mode. Researching the problem i found a ...
1
vote
0answers
32 views

No debug information in Keil when I try to simulate a STM32F103C6 in proteus ISIS

how are you?. I need to simulate a project I what I'm working made with keil in proteus, Labcenter's people enfasizes in that those simulations needs both the .elf file and the dwarf2 file, in Keil ...
1
vote
0answers
44 views

timestamp generator register location on Cortex-M4 (PSELCTRL CNTCR)

I am trying to find the location of the register where the timestamp generator can be enabled on a Cortex-M4 processor. In the CoreSight SoC Technical Reference Manual on page 3-210 it is mentioned ...
1
vote
0answers
37 views

How to prevent OMAP from running software after poweron reset?

I have a faulty forgein system using an OMAP5912 whith external SDRAM and NOR-Flash connected. I have JTAG access to the unit with an Segger J-Flash. Now i want to debug why it does not startup ...
1
vote
0answers
927 views

STM32CubeProg vs STLINK Utility

There are 2 software tools provided by ST to flash their STM32 MCUs namely STM32CubeProg and STLINK Utility STM32CubeProg Page says: STM32CubeProgrammer (STM32CubeProg) is an all-in-one multi-OS ...
1
vote
0answers
121 views

OpenOCD debugger in Eclipse Neon 4.6.2 Error in final launch sequence

I have been struggling with OpenOCD debugger under Eclipse Neon 4.6.2. Whenever I run the debug configuration I receive below given error message I have been attempting to debug the STM32F417VGT6 MCU....
1
vote
0answers
560 views

STM32F103C8 Debugging Using STM Studio (version 3.5.1)

I am trying to obtain real time variable reading in STM Studio But When My STM Board starts running program My STM Studio was unable to detect STLInk V2 and My program Runs only in Flash Mode. I am ...
1
vote
0answers
215 views

Is there any major difference between using STM32F103C8T6 + ST LINK V2 and using Tiva c concerning debugging?

I have started learning ARM microprocessors and I just wanted some real board to get more comfortable with what i'm learning and I have two options : Getting tiva c launch board or using STM32F103C8T6 ...
1
vote
0answers
565 views

Error on Lattice Diamond: “core0 incorrect response (Write: 512 != Read:0) … Problem cause is sample clock too slow or not continuous”.

Question for persons experienced on Lattice Diamond, I'm trying to test a previously developed project on Lattice Diamond. The project initially shouldn't have any problems because it was implemented ...
1
vote
0answers
145 views

Debugger hangs when reaching to Float or Delay

When I run this code, the debugger hangs once it reaches to a Float (in this case the variable 'Distance') or Delay, I mean it seems like it's processing, however it never goes through, and I have to ...
1
vote
0answers
387 views

Problem when debugging ethernet KSZ8081RNB chip on IMX6UL board

I've been working on debugging KSZ8081RNB Ethernet chip for three weeks now and still, I can't find where the problem is. First of all, the board I am working on is including an IMX6UL processor and ...
1
vote
0answers
3k views

STM32 Shutting down debug session

I'm facing with a problem regarding debug session. When I start debug session, after the configuration of USART2 the debug session is closed. Keil message: Cannot access target. Shutting down ...
1
vote
0answers
481 views

How to get Keil Trace to work on stm32f4 for debugging?

I'm using stmf429-disc board with Keil 5.I've enabled trace check in hardware debug's trace window and have set trace clock to 168MHz which is the core clock freq. Also enabled the port 31 for rtx ...
1
vote
0answers
537 views

Debug 2-Wire Serial Interface

How can I debug I2C in Atmel Studio (latest)? I have enabled it as shown inside the I/0 View with TWEN and ...
1
vote
1answer
388 views

How can I take look at the inside of the atmega1280?

I want take a look at the memory and at the elements inside the atmega1280. I compiled Ardupilot sketch and I uploaded it with an arduino. I started avarice with the following command: ...
0
votes
0answers
49 views

How to program and then flash an ARM SAMD21 baremetal?

I want to make a simple program for a custom board with a SAMD21 core, without using any previously existing framework, like the arduino framework. The code to start with is just a simple main() with ...
0
votes
0answers
67 views

Is this port a Cortex Debug?

The following is a board with an STM32F103 MCU. Is it possible to tell if the marked port on the top left (JK1) is a Cortex Debug port that may be connectable with an ST-Link V2 or similar ? According ...
0
votes
0answers
29 views

LG DA-3630 switchmode power supply repair - chirpy sound

I attempted a repair of the switchmode PSU of the DVD player in the title, and while I made promising progress, there is something still missing. Initial problem: when plugged in, nothing happened - ...
0
votes
0answers
20 views

Debugging with ATMEL-ICE in Ubuntu using cutecom

I have an Atmel-ICE-C that I've been using successfully within Ubuntu 18 to program a custom board based on the attiny85 using the terminal and the necessary libraries. I can use a command like this ...
0
votes
1answer
38 views

STM32 STLINK debug port connection with Olimex

I'm currently designing the debug port for my STM32L4R5 microcontroller. I'm planning to use the STLINKV2 debugger but it's using a 20 pin JTAG connector which has a big footprint for my PCB. I saw ...
0
votes
2answers
100 views

Op-amp output oscillating on one of two (virtually) identical circuits

I have a board that connects two analog sensors to an ADC via several op-amps (all MCP6042). One circuit is behaving as expected but the second (virtually identical) circuit on the same board is ...
0
votes
0answers
27 views

Debugging with Blackmagic probe and platformIO undefinedError

As stated, was able to debug using this setup but suddenly I started getting errors. I am able to upload firmware to the target board (STM32 Bluepill) but when I start a debugging session I get the ...
0
votes
0answers
34 views

problems with Lattice Reveal Analyzer - JTAG chain with multiple devices on the chain

I have a board with JTAG chain with 2 devices - (1) TI MCU (2) Lattice MachXO2, in the chain. To be able to program the FPGA, I'm using this configuration in Lattice Diamond: and as can be seen the ...
0
votes
0answers
22 views

Why are there bits changing in reserved section of SPI Read Data register on SAM4LS8AA?

I am trying to establish SPI communication between a ATSAM4LS8AA chip (master) and Hope RFM95W LoRa module (slave). I am using Advanced Software Framework (ASF) in microchip studio (MS), and using the ...
0
votes
1answer
168 views

Debugging STM32 with OpenOCD, STM32 for VSCODE won't work or flash, Configuration issue maybe?

First and for most I googled a lot and Its been a week of searching with no solution at all. Please bare with me! I tried to add all necessary info! Please request more If you need. My problem is: I ...
0
votes
0answers
39 views

Cannot launch GDB client

I am new to embedded coding outside of Arduino, so I need a lot of hand holding. I made a custom board with just a STM32 chip (STM32L082) and a LED. I am trying to debug it using GDB (I hear that's ...
0
votes
0answers
48 views

error mcu not found

I made a PCB contains MCU of Analog device aducm3029, I want to program it via SWD ( An on-board serial wire download (SWD) interface, which is implemented with the Freescale's MК20DX128 ...
0
votes
0answers
21 views

Debugging of RTC (Real Time Clock) using MPLAB ICD4 debugger

I have been searching for a process for debugging an RTC section using a debugger called MPLAB ICD4, but I didn't get an exact result from Google. Can you please suggest me the process? And is there ...
0
votes
0answers
120 views

How to configure STM32CubeIDE with Blackmagic Probe as a debugger?

I am trying to use my Blackmagic probe (an STM32 BluePill converted to a Blackmagic Probe) as a debugging device for the STM32CubeIDE and can't get to work! I tried this solution: https://github.com/...
0
votes
0answers
43 views

How can Quartus Prime System Console be used to read/write a whole file?

I want to find a way to read/write whole file from/to my Intel FPGA design. The file being written provides data to be processed and the file being read shall contain the results of the processing ...
0
votes
0answers
141 views

How to print in proteus console using the internal debug module on a CM3 device

how are you?. There are several ways to debug code in Proteus but I'd like to know another one that is shown in the CM3 help file of Proteus. It has a section called "internal debug module" ...
0
votes
0answers
122 views

Questions about connecting a JTAG ARM 10-pin connector to a TM412x board

I have a TM4C12x board which I want to debug over JTAG. This board does not come with a pin header attached to the JTAG pins, so I need to solder it myself. I have a couple of questions about this: ...
0
votes
1answer
67 views

Counter glitching? Instability? Can't get a trigger lock on the scope, what might that be?

I have a 4 MHz clock and 4 x 74LS161 4-bit counters hooked up to get a 16 bit counter. It's all done how I have done it many times, synchronous with clock going into all the counters and RCO of ...
0
votes
0answers
39 views

Can Quartus System Console be used via Ethernet instead of USB Byte Blaster?

The System Console communicates with the the design inside the Intel FPGA via a JTAG-Avalon MM master. The JTAG connection connects to the Byte Blaster and this is how the debugging works. Is there a ...
0
votes
0answers
78 views

Getting Connection Refused error upon running openocd

I'm having a bit of trouble setting up an openocd debugger in Eclipse. Upon running debug configurations, I get: ...
0
votes
1answer
108 views

Wrong data displayed from UART connection

I have trouble displaying a certain hex string on an LCD. The hex string comes from a external display device that communicates with a serial display. With the oscilloscope, the data from the display ...
0
votes
0answers
47 views

How to receive a startup hex string during a debug session?

This is my setup: I have a 'smart display' connected to the serial interface of a PCB with a PIC microcontroller. The PIC powers the smart display. This smart display uses a boot mechanism. When the ...
0
votes
0answers
36 views

What do I need for Debugging?

I just ordered a 6502, breadboards, eeprom, ... Now where I bought those things to build my own "Computer" on breadboards, I am afraid of not being able to find errors, because I have no ...
0
votes
0answers
67 views

Can I debug this simple circuit without VNA and proper RF equipment?

I am debugging a very simple circuit (existing PCB, not designed by me) that downconverts an AM modulated signal at 900 MHz: The problem: What I measure at "Vo" does not match my LTspice ...
0
votes
0answers
91 views

How to solve the compiler error of USB debugging probe of C2000 series Texas Instrument Microcontroller?

I am using Launchpad-F28027F to generate PWM for buck converter. I am currently using simple example of PWM from Resource Explorer of CCS but it's no working due to the error shown in the below ...