Stack Exchange Network

Stack Exchange network consists of 174 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [st-link]

The ST-LINK is an in-circuit debugger and programmer for the STM8 and STM32 microcontroller families.

0
votes
0answers
11 views

How to read print statements from nRF51822 chip over ST-link V2?

I hope this is the right board for this. If it would be more appropriate elsewhere please let me know. I have a PCB I designed with a Waveshare core nRF51822 B soldered to it. I'm working on writing ...
0
votes
0answers
13 views

STM8S105K4 flash circuit

I recently bought a single STM8S105K4 to fiddle with. I've soldered it to a board and I'm trying to flash it using the stm8flash utility and an STLINKv2. I've made the following connections to the MCU,...
0
votes
1answer
50 views

Programming STM32F407 discovery by the ST-Link V2

I have a STM32F4 Discovery board and a ST-Link/V2 programmer. I want to use my own ST-Link (not the embedded one) for programming and debugging the board. I faced to a problem that i still haven't ...
0
votes
2answers
63 views

How to connect custom stm32 board to debugger

I have a custom STM32 microcontroller board. I have verified all of the electrical connections, and I am able to program the board with Texane's st-flash utility. However, I would like to debug the ...
0
votes
1answer
170 views

USB communication error in ST-LINK v2

I have been trying to program my STM32L476RG micro-controller based breakout board using ST-LINK v2 as programmer. I have hooked every VDD of breakout board to 3.3 V pin of programmer and connected ...
1
vote
0answers
35 views

OpenOCD debugger in Eclipse Neon 4.6.2 Error in final launch sequence

I have been struggling with OpenOCD debugger under Eclipse Neon 4.6.2. Whenever I run the debug configuration I receive below given error message I have been attempting to debug the STM32F417VGT6 MCU....
1
vote
0answers
258 views

Atollic STM32H7 + ST-LINK Error writing data to flash with math library

I am currently working on a STM32H743VIT6 chip (on a self-designed board), with the Atollic TrueStudio toolchain (ver. 9.0.0), using a ST-LINK debugger on a STM32F4-Discovery board (ST-LINK firmware ...
2
votes
2answers
359 views

Can one program an STM32H7 chip directly using an ST link/V2

I recently bought an STM32H7 chip, soldered onto a breakout board. I have been trying to program it using the ST-link/V2 using system workbench for STM32. I get the error: "Wrong device detected". The ...
0
votes
0answers
89 views

STM32F723 custom board debugging/programming issue

I am working on custom board design for STM32F723ZET6 MCU. Here is part of schematic. All the VDD/VDDA/VBAT pins are connected to 100nF bypass capacitors and few 4.7uF capacitors between VDD and GND....
1
vote
1answer
164 views

ST-Link V2 Programming STG-850 PLC — STM32

I'm trying to connect to a Barth STG-850 PLC for the first time and am using the ST-Link V2 programmer (not the ISOL version) and have been unsuccessful so far. The crux of my problem likely stems ...
0
votes
0answers
92 views

STM32F0 SWD not working VDD >2.9V

I made a board with a STM32F031 and connected it to the ST-Link integrated into a STM32F4-DISCOVERY. To this point I was able to figure out, that the SWD connection works, if I supply a voltage of <...
0
votes
1answer
238 views

STM32F7 programming problems

I am trying to program an STM32F7 series MCU on a custom PCB (migrating over from a nucleo dev board) but I am having trouble connecting to the MCU. Using STM32CubeProgrammer (the new programming ...
0
votes
0answers
258 views

Using a nucleo board as ST-link for STM32F722RET6 (Error: ST-LINK error (DEV_TARGET_CMD_ERR))

we have disconnected the ST-link from the nucleoboard and prepared it correctly for its use. we connected it back to the nucleoboard, and everything worked like it should. We want to use this ST-link ...
0
votes
1answer
221 views

Power consumption of Nucleo L432KC board

I'm currently developing an IoT LoRa node using a Nucleo L432KC. I want the node to be alive more than a year, so I want to test its energy consumption very carefully. I intended to cut off any ...
0
votes
0answers
395 views

How to use JTAG to connect external ST-LINK/V2 with STM32F407VG discovery board? [duplicate]

I want to isolate the on-board stlink, and use an external ST-Link/v2 to program/flash the board. I have a 20-pin JTAG connector. This is just a temporary, proof-of-concept project. I have removed ...
0
votes
2answers
2k views

STLINK V2 disconnects in the STLink Utility

I have some strange behaviour of my STLINK V2 when I just plug it in the USB port and then open the STLINK Utility tool. When I then go to settings it finds the STLINK V2, but after about 5s the ...
0
votes
0answers
40 views

Flashing STM32L0 - QSTlink2

When I am trying to flash STM32L073RZ using QStlink2 with .bin file which was built in Eclipse, QStlink throws following errors: ...
0
votes
1answer
868 views

Converting ST link v2 to Jlink [closed]

Has anyone had any succes with converting a ST link v2 to a Jlink using the software that Segger provides? I have not had any success, even with using instructions they provided and was wondering if ...
2
votes
1answer
1k views

Error when using debugging under Atollic TrueStudio / STM32

I'm using STM32F103C8T6 Atollic TrueStudio STLink2.1 Error I get when debugging: Debug configuration set in TrueStudio: What worked before was in SW4STM32/Eclipse, with the following settings. I ...
1
vote
0answers
166 views

Samd21g18a Bootloader upload with ST link V2

I was wondering if anyone had any success with uploading a bootloader with an ST Link V2 to a Samd21 chip using OpenOCD or any relevant IDE and was willing to send me in the right direction. I have ...
0
votes
0answers
3k views

ST-LINK “USB communication error”

I have a custom PCB (based heavily on the Nucleo board) using the STM32F767II. I am using Atollic TrueStudio on Windows 10 and programming it through the ST-LINK on the Nucleo board (header CN6). I ...
0
votes
0answers
146 views

Problems connecting ST-Link V2 and LPC1114 board

I'm unable to connect to my LPC1114 board using an ST-Link. my lpc 1114 package software settings: result I also have tried push and hold reset button click target -> setting, select "connect ...
1
vote
2answers
340 views

STM32F4 without ST Link module

I ordered an STM32F4xx board to use it in an embedded systems class a couple months ago. It has arrived yesterday and I figured out it does not have the ST Link module included. How can I program it? ...
6
votes
3answers
3k views

Do I really need to put stm32 microcontroller into bootloader mode to program it?

I have started learning stm32 microcontroller for a while using a very small development board "stm32f103c8t6" (or blue pill). when I started, I learnt from some tutorials that I have to switch a ...
2
votes
1answer
855 views

Programming a new STM32 chip

I am new to STM32 and recently trying to make a custom board with STM32F103RB. But I am a bit confused by the available methods to program the chip. Let's say I use ST-Link via SWD, does it mean that ...
0
votes
2answers
746 views

ST-Link connection suddenly stops responding

While I wanted to upload/debug a new HAL Eclipse System Workbench for STM32 project on my STM32F103 it showed the following message: ...
1
vote
1answer
2k views

Atollic + STM32F4 + ST-Link v2 connection problem “Unknown MCU found on target”

I currently have a problem with the connection between the debugger ST-Link V2, ARM Atollic 8.0.0 and a custom board with STM32F469. The Atollic and the ST-Link utility believe the Target is halted (...
0
votes
1answer
104 views

how to use external st-link v2 with evaluation board STM32F469NI

I tried to use external ST-LINK V2 with evaluation board STM32F469NI. I connected it to the connector CN16, disconnect USB from CN22 and used ST-LINK utility. But connection to target MCU was failed. ...
1
vote
2answers
3k views

STM32 & ST-LINK - SWD connector not working

I am using an ST-LINK/V2 debugger (Firmware version V2.J27.S6, up-to-date) to program my STM32F407G discovery board. So far, I have been using USB to flash the MCU, using the STM32 ST-LINK Utility v4....
0
votes
1answer
1k views

STMicroelectronics ST-LINK/V2-1 USB driver for macos?

I am trying to connect to my MacBook Pro the eval board: STEVAL STLCX01V1 from STMicroelectronics so I can try programming the SensorTile. I am using OpenSTM (System Workbench).
0
votes
0answers
441 views

Problems connecting ST-Link V2 and STM32L4 discovery board

I'm unable to connect to my STM32L4 Discovery board using an ST-Link. I've removed jumpers from CN3, connected the cables correctly but the utility tool won't detect anything... PIN1 -> 3V3 ...
-1
votes
2answers
338 views

STM32F103 memory addressing

I have written my code for STM32F103C8T6 board in Keil using the adequate startup files. I wrote directly to the memory addresses using information from the datasheet but the ST-Link upload seems to ...
1
vote
1answer
2k views

Is it possible to get ST-LINK's virtual COM port working without launching any program in Ubuntu?

I did some development on a Nucleo-64 board (specifically the NUCLEO-F303RE with the STM32F303RE microcontroller) and used OpenOCD and GDB with target remote :3333 ...
8
votes
3answers
4k views

Can I use ST-Link programmer for non-ST chips?

Can I program all kinds of SWD-programmable chips (ARM-MCUs) with ST-Link?
0
votes
0answers
375 views

STM32 'Connect under reset' suddenly stopped working

For the last few months I've been working on a project that used an STM32F030 microcontroller. Due to a shortage of GPIO I've had to use the SW debug pins for other functions. Until recently this wasn'...
1
vote
1answer
3k views

STM32 prototype unable to connect to PC using ST-Link/V2 SWD

Circuit Diagram Background & What I have tried. I have wired wrapped this setup myself using a fresh STM32F411RC MCU from digikey (on a proto-advantage LQFP-64 to DIP-64 breakout board). I've ...
3
votes
2answers
13k views

Problems connecting ST-Link V2 and STM32F4 discovery board

I'm unable to connect to my STM32F4 Discovery board using an ST-Link. I've removed jumpers from CN3, connected the cables correctly but the utility tool won't detect anything... ...
2
votes
1answer
926 views

Using ST-link for 1.8V target voltage

I'd like to program a LIS331EB which is an ST product with an integrated cortex-M0 core. ST says it can be programmed with ST-link even though it is neither an STM32 nor STM8. The lis331eb's core and ...
0
votes
1answer
424 views

How to use ST-LINK Utility

Could someone be kind to explain some features inside ST-Link Utility. What is the unit of measurement for size, how it works? What does represent data width? Changing data width presents different ...
12
votes
2answers
37k views

How to use external ST-Link to debug/program STM32F103 MCU?

I'm using STM32F103 MCU for my own project and want to use the ST-Link of STM32F411 Nucleo board for external debugging / programming purposes. I've set the CN2 jumpers OFF and my actual question is ...
7
votes
7answers
46k views

STM32 & ST-LINK - Cannot connect to MCU after successful programming

I have built my own board with STM32F7-45VGT6. I have successfully programmed it with ST-LINK v2 (not the original one though) and now I cannot even connect with MCU. I use ST-Link Utility from ST ...
0
votes
1answer
446 views

STM32F103: ST-Link doesn't actually update the firmware upon reprogramming unless I relaunch ST-Link

I've just got a new STM32F103 board instead of the F3 Discovery, can't get OpenOCD working, so I'm stuck with ST-Link for re-flashing. And I've spent 3 to 4 hours today trying to figure out why my ...
0
votes
1answer
1k views

Stop blinking LD1 on STM32F4 Discovery

I have a system I built using a ADS1263 32-bit ADC that is measuring tiny biopotentials without much amplification (for a variety of reasons not under discussion) -- one very low noise instrumentation ...