2
\$\begingroup\$

I bought the following UPS module for my Raspberry Pi: Power Pack Pro

The module kinda works, when I unplug the power cable, the module instantly switches to battery powered mode without restarting the Pi. Also the I2C output works, I am able to read the voltage of the battery.

BUT: It cannot provide enough power for the Pi. The lightning bolt is there 99% of the time. It disappeared in absolutely random times, even during a CPU stress test.

I tried the followings:

  • with 3 different Pi 3 and 3b+
  • multiple charging cables (which are totally fine with normal usage)
  • 5V 3A charger
  • tested the UPS board with a fully charged battery (+ external power), without a battery (only external power), and with only a battery (without charging), but still the same
  • the module also has a micro usb out, so I bought a male-to-male cable. It looks like the output voltage is 5.0V which even drops when I power up my Pi.

After these I contacted the seller and asked for a replacement board. I got one. The new one has all of these symptoms.

(I even asked a YouTuber if he has the similar problems, but he said no. Other reviews were also positive)

The reason why I ask you about this problem is I found out my board has different chips than what displayed on the official wiki.

Photos of my board: drive

I was able to read (sort of) the numbers from the chips:

  • U1: IP5306 20HG00FA(?)
  • U2: ETA1096 6312F
  • U3: LM393 SSM FK52
  • U4: 2015CS AD9T8H(?)

I'm a beginner in electronics, but I can't think of anything else but I have these problems because of the different electronic parts. Can I make a working module by resoldering different (working) chips into the board?

Edit: (note) the module is no longer for sale.

Edit 2: I made a comparison image of the advertised/received boards: image

  • The U1 chip is different. The others look like they're the same.
  • The 2R2 inductor is flipped, but if I'm correct, that's not a problem.
  • Some capacitors are changed to ceramic ones.

I hear some static noises under use, but I can't tell what is the source of it.

\$\endgroup\$
  • 1
    \$\begingroup\$ Are you connecting RPI only? Or it has some peripherals as well? You have mentioned 3A supply - did it work? RPI 3-3b has a recommendation of steady 2A supply, so your PowerPack is on the edge. \$\endgroup\$ – Eugene Sh. Jun 5 at 15:43
  • \$\begingroup\$ Only the RPI. I have several power supplies 2A, 3A (quickcharge) and an official Raspberry 2.5A one. They all can provide enough voltage using on their own. The module is officially for the RPI 3, that's why I tested it with a 3. But others claimed it's fully functioning with their 3b+ also (but for me, not). \$\endgroup\$ – Adam F Jun 5 at 16:03
  • \$\begingroup\$ The ESR (due to C rating) and/or mAh quality of the battery may be the cause. \$\endgroup\$ – Tony Stewart Sunnyskyguy EE75 Jun 5 at 16:16
  • \$\begingroup\$ I do have the exact same problem. Also sometimes the battery stops charging and is discharged until empty. \$\endgroup\$ – sonntam Aug 4 at 12:08
  • \$\begingroup\$ @sonntam that's weird, I never encountered that problem. I only noticed that the 4th charging led is almost always flashing, indicating the battery will be fully charged soon, but not. \$\endgroup\$ – Adam F Aug 6 at 11:05
1
\$\begingroup\$

If you search the Web for this issue you will find LOTS of people that have tried everything to get rid of the "under voltage" indicator. The problem seems to often be the power supply or the cable being used.

In your case it sounds like you have tried everything!

This is not a fix of your problem, but it is a way to get rid of the under voltage warning.

Be sure to read about what MAY happen when the Pi is operated with what it believes to be low power.

Disable Under-voltage Warning (Not Recommended) Under-voltage may cause problems, disabling the warning just gets rid of the warning, not the reason it is triggering.

Open /boot/config.txt file.

sudo nano /boot/config.txt

Add this to the file, save and close the file.

avoid_warnings=1

Once saved and closed then reboot.

\$\endgroup\$
  • \$\begingroup\$ Yes, I know this problem, it happened with me in the past with a cheap cable. Question: does the "under voltage" indicator appear when there is enough voltage, but not enough current? I really do not want to disable the warning because when I attach this module I hear this "PSU noise" which bothers me a little. \$\endgroup\$ – Adam F Jun 6 at 12:44
  • \$\begingroup\$ Voltage and current are related to each other, without one you cannot have the other. If there is not enough current the voltage will go down. The Pi's built in regulator circuit is what signals if the voltage is low. If there is not enough current the voltage will be low. After looking at the link you provided, the Power Pack Pro is listed with an output of MAX 2A. This is not enough current for a Pi, I have several products that are based on the Pi, I use 3A supplies on them. Also I keep the power cords as short as I can because there is quite a bit of loss in them if they get very long. \$\endgroup\$ – Wendall Jun 6 at 13:25
  • \$\begingroup\$ Had the same issue with my Pi .. I used a non-Pi power supply, and it went nuts.. I finally gave in and bought the official Pi supply and it solved the issue. Overly sensitive board ..... sigh \$\endgroup\$ – Sorenp Aug 6 at 12:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.