0
\$\begingroup\$

I have a device like this https://www.vaisala.com/sites/default/files/documents/WXT530-Users-Guide-M211840EN.pdf.

Some facts:

  • I have an FTDI to USB board from Sparkfun which is tested to work with other serial devices, so it's not broken.
  • The device mentioned above is correctly wired for RS232 and is tested with an USB -> DB9 on 19200,8,N,1 to work correct both on Mac and Windows.
  • The serial device prints ASCII characters one line at the time which is ended with <crlf>

My problem:

When I wire the serial device to the FTDI to USB and I use the correct baudrate, I get garbage out. I have spent numerous hours to fix this and I can't figure out the problem.

If someone have ideas, that would be appreciated.

Things I have tried :

  1. I tried 2 different USB to DB9 that work fine both on Windows and Mac
  2. I tried the mentioned FTDI from Sparkfun both on Mac and Windows, same problem -> garbage.
  3. On the Vaisala device, I have connected SGND (Serial Ground) with the Vin - no difference.

My ultimate goal is to connect the Vaisala serial device to the serial of an ESP8266, but until I understand this problem I can't continue. Actually I did try to connect it and I also get garbage here too.

\$\endgroup\$
  • 3
    \$\begingroup\$ There is no such thing as an FTDI to USB board. There are, however, UART to USB boards and RS232 to USB boards using FTDI chips. \$\endgroup\$ – DKNguyen Jan 27 at 19:56
  • 1
    \$\begingroup\$ The linked user's guide is 222 pages. Please show an excerpt related to the serial communications interface that you are trying to use. Also, carefully check and list the voltage levels used by your FTDI board. \$\endgroup\$ – Elliot Alderson Jan 27 at 19:59
  • 3
    \$\begingroup\$ You could try scoping the RS-232 to see if anything @KingDuken says might be true. \$\endgroup\$ – DKNguyen Jan 27 at 20:07
  • 3
    \$\begingroup\$ It appears that the Sparkfun FTDI board uses "TTL" levels, rather than RS-232. The TTL signal is inverted relative to RS-232. The FTDI board is for use with Arduino and other devices that do not have the RS-232 line drivers that invert the signal. USB->DE9 cables will normally have RS-232 line drivers. \$\endgroup\$ – Peter Bennett Jan 27 at 20:35
  • 3
    \$\begingroup\$ @PeterBennett I guess that's why its important to accurately know/say whether you have a RS-232 to USB board or a UART to USB board. \$\endgroup\$ – DKNguyen Jan 27 at 20:39
4
\$\begingroup\$

You have a USB to serial converter provides a serial interface that uses 5V or 3V TTL/CMOS voltage levels. The Vaisala device provides a serial interface that uses RS-232 voltage levels. These are incompatible. You need a USB to serial converter that also provides a serial interface with RS-232 voltage levels.

\$\endgroup\$
  • \$\begingroup\$ So i am not entirely sure, does that mean that i can't use the Sparkfun at all meaning i most likely have same issue with my ESP8266. Sine ESP is the end goal, what do i need, i need a middle man ? \$\endgroup\$ – dbrasco Jan 27 at 20:38
  • 3
    \$\begingroup\$ To convert TTL/CMOS levels to RS-232 levels, you need a RS-232 tranceiver chip or ready made board that has one. I would guess these are available from any hobbyist shops, including the one you mentioned. \$\endgroup\$ – Justme Jan 27 at 20:40
  • \$\begingroup\$ Thank you all, i know what to do now. Sorry if i have mislead you. Now i know the difference between TTL and RS232 \$\endgroup\$ – dbrasco Jan 27 at 20:41
  • 1
    \$\begingroup\$ @dbrasco: Have a look at my answer to why-cant-i-successfully-send-messages-over-rs232 which was very similar to yours. Notice the debugging and information that the poster supplied was much more specific than "garbage" and facilitated successful analysis of the problem. \$\endgroup\$ – Transistor Jan 27 at 21:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.