0
\$\begingroup\$

I've got a male micro USB connector like this one

enter image description here

I'm feeding the output of a buck converter set at 5V to pin 1 positive and pin 5 negative. Remaining pins are not connected. When I plug the connector in, the screen turns black and only the back and menu (or whatever it is) buttons are still lit but do nothing. After disconnecting the cable the phone remains like this for ~15 minutes and resets to normal.

If I plug in an ordinary charger the phone charges without a problem.

I have not done anything to the phone it's a stock android device.

It probably expects something on the not connected pins? I found that some chargers may put resistance between the data pins to indicate available current rate but is not standard so it should not be mandatory..

What do I need to do so I can charge the phone with the minimum 500mA?

EDIT:

I shorted the data pins as per USB 2 standard for a dedicated charging port and the screen phenomenon now happens only every other try.

After connecting, switching the power supply on and off does not cause the freeze but when off current is drawn from the phone.

Increasing the voltage to 5.25V resulted in ~125mA flowing to the device but without any indication of charging on the screen.

\$\endgroup\$
  • \$\begingroup\$ If you could specify the model of your phone, we could search for the info on what it expects on its data pins in order to charge at a larger current. \$\endgroup\$ – Edin Fifić Apr 18 at 15:19
  • \$\begingroup\$ @EdinFifić it is a nokia 6 \$\endgroup\$ – php_nub_qq Apr 18 at 15:38
1
\$\begingroup\$

Measure the current draw. My guess is you're only getting ~100mA. You could try shorting the USB data pins, as that is the USB 2.0 standard for a dedicated charge port. However, you know what they say about standards. Not all phone manufacturers will recognize a DCP, and worse, others expect some other weirdness (looking at your Apple and Samsung) on the data pins to fast charge.

| improve this answer | |
\$\endgroup\$
  • \$\begingroup\$ What is a possible reason for that? Its a 3A (rated, more like 1.5A) buck converter and there is nothing else connected. \$\endgroup\$ – php_nub_qq Apr 18 at 14:57
  • \$\begingroup\$ The phone does not know it can draw over 100mA even if you are able to provide 10A. Unless you do something with the data pins so it knows it can draw more. \$\endgroup\$ – Justme Apr 18 at 15:03
  • \$\begingroup\$ @php_nub_qq The buck converter rating is irrelevant. The charge current is controlled by a battery management IC, or possibly the main SOC depending on the phone. Regardless, this all happens inside the phone and you can't control it other than emulating whatever behavior is expected on the data pins. \$\endgroup\$ – Matt Young Apr 18 at 15:03
  • \$\begingroup\$ I just measured it. Unfortunately I dont have an oscilloscope to give more detailed information though. My multimeter reads 1.45A for like half a second or something and then the screen turns black as described and there is no longer current flowing \$\endgroup\$ – php_nub_qq Apr 18 at 16:51
  • \$\begingroup\$ I also shorted the data pins and the screen no longer turns off. It starts charging for a fraction of a second and then stops, after trying this about 5 times it reverted to the old behavior. \$\endgroup\$ – php_nub_qq Apr 18 at 17:07
0
\$\begingroup\$

Well, given all the information in comments and edited in the answer, nothing seemed to work.

I modified an USB cable in such manner, using a proper charger

schematic

simulate this circuit – Schematic created using CircuitLab

And it still refused to charge. I tried adding some resistance - 47, 100, 200 ohm, still nothing.

So in the end I bought a charger like this one

enter image description here

to which I added a fuse and a power transistor and I skipped the buck converter altogether.

I'm not going to accept this as it's not an answer to the original question but is a workaround that worked for me.

| improve this answer | |
\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.