1
\$\begingroup\$

Before this I'm launching my modified version of LoRaWAN_End_Node firmware, but my Nucleo Board keeps restarting and heating up so I unplugged the USB cable. When I tried to connect my board back I get a FAILS.txt file with the following content

The interface firmware FAILED to reset/halt the target MCU

I tried to connect my MCU to the STM32Cube Programmer with under reset configuration and trying all reset mode configuration but got no luck.

Other things that I've tried:

  1. Disconnect JP1
  2. Connecting while pushing the reset button
  3. Doing point 1 and 2 at the same time

And still got no luck.

enter image description here

UPDATE #1

  1. Replugged the JP1 jumper and the heating issue is back (The MCU isn't completely dead, I guess (?))
  2. It is a Nucleo Board so it should be using an official ST-LINK
\$\endgroup\$

1 Answer 1

2
\$\begingroup\$

I believe that your microcontroller is in fact dead. If there is a problem with your board heating excessively and it cant read/write data then there is definitely a short somewhere. My best guess would be either the interface chip (connects your usb to the microcontroller) or the MCU itself is shorted. If you have a multimeter and a lot of time or a thermal camera you can see what is shorted. You might just want to buy a new development board instead, as that would save a lot of time (The nucleo is an interface that will let you easily program a MCU, not the MCU itself. It includes a crystal oscillator as well as the aforementioned interface chip along with regulators and such)

\$\endgroup\$
3
  • \$\begingroup\$ Well, the worst case is happening then. Thought it was because a minor software bug since I'm new in STM32 and the heating issue is gone because it only happens if I use the LoRaWAN. Tried on a different board and the heating issue is gone with LoRaWAN program flashed. Guess the LoRa chip was defective and somehow damaged the MCU chip. \$\endgroup\$ Mar 10, 2023 at 14:54
  • \$\begingroup\$ Anyway, are there any tip(s) to prevent this kind of thing happens (from software side since I use the Nucleo board)? I don't wanna fried the spare board since it's kinda expensive lol. \$\endgroup\$ Mar 10, 2023 at 14:55
  • 1
    \$\begingroup\$ I don't think there is any problem on the software side, It is probably a defective part. \$\endgroup\$ Mar 10, 2023 at 15:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.