3
\$\begingroup\$

I'm currently using LTspice, and I have a problem with it "never" finishing calculating a certain circuit. When I say "never", I mean that it's still calculating an hour after it started, even though the review-time is less than two periods of the input sine.

In the program status field it says: "Stepping Source: 100% step size=6.8413e-005 N-R iterations: changes frequently between numbers spanning from 0 to 200 fill-ins: 4". It seems to be stuck at this point.

The circuit I'm talking about is this frequency doubler.

Does anybody know a solution to this problem? If there is no solution, can you suggest a program that will not get stuck like this?

\$\endgroup\$
  • 1
    \$\begingroup\$ When I've run into this issue, its because I haven't declared my load as an active load. Undoubtedly you have declared an input to the circuit and most likely some sort of load for the sake of LTspice. Can you post your LT schematic? \$\endgroup\$ – Funkyguy Jan 9 '15 at 20:10
  • \$\begingroup\$ It was faulty wiring in the XOR-gate because of a misunderstanding. It works now. Thank you for commenting! \$\endgroup\$ – paw Jan 9 '15 at 22:17
2
\$\begingroup\$

When I get those errors, it is usually because the SPICE model from the manufacturer is wrong or broken, or that your SPICE settings are wrong (open the LTspice's Control Panel and click Reset on the SPICE tab).

I tried implementing the circuit from your application note in LTspice and it worked (it is here), but:

  • I used the LT1720 since it was already in the LTspice libraries has a 4.5 ns propagation delay and the MAX9010 has 5 ns;
  • The XOR gate is set to have a 4.8 ns propagation delay (from the datasheet).
  • The clock source is 15 MHz.

enter image description here

This gives me:

enter image description here

As you can see, the pink trace is roughly twice the frequency of the green one (the input signal), working as expected.

I tried using the MAX9010 SPICE model, but had to edit it to put the pins in proper order, and the output looked wrong.

\$\endgroup\$
  • 1
    \$\begingroup\$ I'm not very experienced with LTspice, and this is the first time I use the XOR-gate. I needed to find out about the terminals, and some source on the web said that all unused terminals would have to be wired to terminal 8, for some unknown reason. I forgot all about it and therefore didn't try to undo them when I stumbled upon problems. I undid them as soon I saw your schematic Renan, and it works perfectly now. Thanks! \$\endgroup\$ – paw Jan 9 '15 at 22:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.