0
\$\begingroup\$

I power voltage regulator by 12V / 8A power supply.

UA78S09 is responsible to convert voltage to 9V for DC motor, which is able to swallow 1,5A at start and under heavy load. Motor however does not start even if specs for regulator states that it should be capable to provide 2A current.

Multimeter shows proper voltage 9V but max current peaks on around 0,4A only (only multimeter - no motor connected).

Why is that so? BTW: I have attached heat sink to regulator (if it matters here) and do not use capacitors.

Disclaimer: I am total noob, just started playing with simple circuits. So please be gentle with me ;-)

\$\endgroup\$
  • 1
    \$\begingroup\$ You need to show at least some schematics and measurements. Also if the voltage is the nominal 9V and the motor draws only 400mA then its not the fault of the regulator \$\endgroup\$ – PlasmaHH Apr 12 '16 at 12:18
  • \$\begingroup\$ It is not the motor which draws 400mA. Multimeter shows that on shorted circuit. \$\endgroup\$ – Lukasz Apr 12 '16 at 12:27
  • \$\begingroup\$ See the answer from AndyAka. The regulator has short circuit protection, and limits to around 500mA. Connecting an ammeter the way you describe shorts the output to ground and triggers the short circuit protection. \$\endgroup\$ – JRE Apr 12 '16 at 12:32
  • 1
    \$\begingroup\$ @Lukasz: If your multimeter shows 9V and 400mA on "short circuit" then it has a pretty hefty shunt resistor... \$\endgroup\$ – PlasmaHH Apr 12 '16 at 12:46
2
\$\begingroup\$

If the voltage is 9V the regulator is doing its job. Its job is to output 9V (give or take) when the load is somewhere between 0 and maximum current (provided you don't let it overheat). It is doing that.

The motor will draw more current if you put a load on the shaft, but it's not the regulator's job to force current through the motor.

From your comments, I conclude that the 9V is not what the regulator is outputting when the motor is not moving. A quick look at the datasheet indicates that this particular regulator has foldback current limiting, so the output current will drop to approximately 500mA typically on overload (with 27V in, so 400mA is quite plausible with only 12V in).

So it's likely unsuitable for driving your particular motor where the start-up surge exceeds the built-in current limit.

There are several circuits shown in the datasheet which I linked above showing how to increase the current capability. The simpler one does not have short-circuit protection so testing it into a short circuit might have ill effects.

enter image description here

You will be running pretty close to the dropout voltage with such a circuit however, so it might not maintain 9V out.

Don't leave the recommended capacitors out! A bit higher values won't hurt, but they are recommended for good reasons, even though it's not your problem in this case.

\$\endgroup\$
  • \$\begingroup\$ I know it is not job of regulator to force current but it is stil its job to be able to provide enough current on request (2A according to specs). When I connect the same motor to the 9V standard battery I see on multimeter that it can draw as much as 1,5A but when connected do regulator - it does not even move. \$\endgroup\$ – Lukasz Apr 12 '16 at 12:25
  • \$\begingroup\$ Perhaps the information you gave that the output is 9V is not correct then. Of course we are talking about when the motor is connected and running, the output voltage should be 9V. \$\endgroup\$ – Spehro Pefhany Apr 12 '16 at 12:26
  • \$\begingroup\$ For higher current circuit: Can I replace bd536 transistor with any other (I have some popular ones: 222...) or is it special one? \$\endgroup\$ – Lukasz Apr 12 '16 at 16:30
  • 1
    \$\begingroup\$ It's a 50W TO-220 transistor. Any similar POWER PNP transistor (probably TO-220 or TO-246 case) can be used (eg. 2N2955). It will need a heat sink. \$\endgroup\$ – Spehro Pefhany Apr 12 '16 at 17:27
2
\$\begingroup\$

Here's my best guess...

The volt drop across the regulator is 3V (12V - 9V) and initial current required by the motor could easily be 2A. This is a power dissipation of 6 watts (in the device) and, without a heatsink fitted, the T0-220 package of the device will warm up at 50degC per watt. This will be fairly rapid and exaggerated by the current limiting so, the device will thermally shut down and you might get a small twitch in movement of the armature.

If you have a heat sink fitted it needs to be in the order of less than 15 degC / watt thermally.

Note also that current limiting inside the chip folds back to typically 500 mA but this may get lower as the excessive heat produced by the device causes thermal shut-down.

You MUST use input and output capacitors.

\$\endgroup\$
  • 1
    \$\begingroup\$ The current limiting is it. The datasheet says "Short circuit current at Vi of 27Volts is 500mA." \$\endgroup\$ – JRE Apr 12 '16 at 12:31
  • \$\begingroup\$ Isn't that strange that motor does not even start? Shouldn't it take at least few moments (1-2 seconds) for a heat to build up before thermal protection kicks in? One fellow from electronics shop suggested it could rather be that motor's initial, momentary current required to start is is too big - much bigger than 2A. Is that possible? \$\endgroup\$ – Lukasz Apr 12 '16 at 18:44
  • 1
    \$\begingroup\$ Starting current can be several times bigger than full-load current. It's basically the same as the stall current. \$\endgroup\$ – Andy aka Apr 13 '16 at 7:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.