2
\$\begingroup\$

I have a problem when placing my components on the board. altium restrict my movement. It is like some design rule are not showing up but blocking me to put components the way I want.

I think I have activated a function but I don't know which one who make that I can not place components the way I want.

Edit: Does anybody knows what I have to change ?

When I try to place a component A close to another one B, the compnent A can not go closer to B. It is same than like a design rules apply making that I can not place the way I want. Altium block the move as if there is a clearance between both components. Normally the DRc would turn the component green. Here it doesn't turn green it just block the move

It is typically avoiding or blocking obstacles...

\$\endgroup\$
  • \$\begingroup\$ Please give us some information about the restrictions it is applying. You are very close to the problem, but we only have what you tell us to go on. So please try to help us help you. \$\endgroup\$ – gbulmer Jun 9 '16 at 15:15
  • 2
    \$\begingroup\$ I cannot move into my house. Do you know whats wrong ? Do you see the problem with my question ? Now look at your question. \$\endgroup\$ – efox29 Jun 9 '16 at 15:15
  • \$\begingroup\$ @gbulmer : When I try to place a component A close to another one B, the compnent A can not go closer to B. It is same than like a design rules apply making that I can not place the way I want. Altium block the move as if there is a clearance between both components. Normally the DRc would turn the component green. Here it doesn't turn green it just block the move \$\endgroup\$ – user92481 Jun 9 '16 at 15:26
  • \$\begingroup\$ Please update your question so that the question itself provides the information needed to answer. New readers should not have to read the comments to understand the question. \$\endgroup\$ – The Photon Jun 9 '16 at 15:38
  • 2
    \$\begingroup\$ So are you saying it's not being caused by the Component Clearance rule? techdocs.altium.com/display/ADRR/… \$\endgroup\$ – DigitalNinja Jun 9 '16 at 17:08
4
\$\begingroup\$

Give this a try:

Go to your DXP menu --> Preferences, expand "PCB Editor" in the left pane, and select "Interactive Routing". Under the "Dragging" heading, make sure "Component pushing" is set to "Ignore" instead of "Avoid".

enter image description here

When set to "Avoid", I believe this rule follows your component clearance rules and does not allow you to place a component within that clearance (near another component).

\$\endgroup\$
1
\$\begingroup\$

Fond the problem!! it is not a issue, it is a new placement option.

select the component to move, and press "R", then you can put the component closer as you want.

from Altium on-line help:

http://techdocs.altium.com/display/ADOH/((Smart+Component+Placement))_AD

"Placement Modes

You can cycle through placement modes by pressing the R key during placement. •Ignore Obstacles - Regular placement behavior, as seen in previous versions of Altium Designer. In this mode, the same component clearance checking routines seen in previous version of Altium Designer are used. These routines use the 3D body, if there is one, or the copper and silk primitives to identify an object's clearance. •Push Obstacles - The component to be placed will push other components away to provide compliance with clearances between components. Components in unions can be pushed and the location of components in the union may change, but the union will not break. Locked components can not be pushed. In this mode, components are identified by their selection boundary, which is the smallest possible rectangle that encloses all of the primitives in the component. •Avoid Obstacles - The component to be placed will be forced to avoid violation clearances between other components during placement. In this mode, components are identified by their selection boundary, which is the smallest possible rectangle that encloses all of the primitives in the component.

The status bar at the bottom of the workspace indicates the current placement mode. " HTH

\$\endgroup\$
  • \$\begingroup\$ This is basically the same as my answer, but a less permanent solution. \$\endgroup\$ – DerStrom8 Aug 28 '16 at 1:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.