0
\$\begingroup\$

I bought a Philips PM 3253 oscilloscope (and got it working thanks to Electrical Engineering stackexchange, thanks for that).

However, I have a new problem. I probe to the calibration output which gives 2 KHz, 600 mV.

Initially, 0.2 V/div is selected (see yellow circle below), multiplied by 3 boxes = 0.6 V (is ok). See [Initial1

However, than I change the know to 0.5 V/div (see yellow circle below). However, the electron beam does not change (not ok). See: enter image description here

When I press the Erase button I see the correct output, meaning 0.5 V/div * approx 1.2 boxes = 0.6 V. Ok again. enter image description here

Also when I change anything else nothing changes unless I press the Erase button. I'm sure it worked before and tried a lot of switches/buttons, but it is probably a combination.

Do you know how to change the electron beam immediately without having to press the Erase button every time?

Update: After testing a lot, now changes are more or less automatic. I think the electron beam is really old, and I have to very delicately set the Intens button .... if it is too low, it will not show anything, if it is too high, the old lines will remain (even after removing the probe). To make it more tricky, after the signal change, a bit more Intens is needed, so I have to move that dial a lot (or press the Erase button). I wonder how many problems I will get when looking at a changing signal.

\$\endgroup\$
  • \$\begingroup\$ If you look at how a CRO works, this seems to indicate the scope is doing things you don't want it to (Storing signal). Old CRO scopes didn't even have the ability to "store" waveforms like yours is doing, indicating something is still up. \$\endgroup\$ – Joren Vaes Apr 29 '17 at 5:55
  • \$\begingroup\$ Yes I know I have a storing/memory CRO (and found out that is quite unusual). But I found out the signal is being updated when playing with the Intens knob (not used really for the store, which is the Store knob, two knobs right of the Intens knob). Still analyzing a bit what is wrong (but I think it's just old and has a not so good electron beam anymore). \$\endgroup\$ – Michel Keijzers Apr 29 '17 at 12:29
1
\$\begingroup\$

Turn this knob to Normal, it should click ...I think you have it set to Store:

enter image description here

|improve this answer|||||
\$\endgroup\$
  • \$\begingroup\$ If I turn it to the right (store) I don't see anything. However, I think I found the problem (I will update it in the question). \$\endgroup\$ – Michel Keijzers Apr 29 '17 at 2:07
  • \$\begingroup\$ The oscilloscope works, but it is far from a good quality beam. For non moving waves it is sufficient though. \$\endgroup\$ – Michel Keijzers May 21 '17 at 22:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.