1
\$\begingroup\$

I am using an FTDI USB to Serial cable to read the startup log of a board. The FTDI cable is not reading the correct information coming from the board. Here is some of the information that I am seeing when I look at the Tera Term Terminal.

"¿aY'¿3;9!#%='5 5¿-9-!#¿%5%£¿777-5¿777-5#7;!!£%!75%#!#5¿=#7;!!£5'#! 5#!'¿=#7;!!£!9/A5#7!-7¿=#7;!!£!9/A=#5'A-7¿=#7;!!£!9/A35=¿=#7;!!£;!!'!=75£££¥¥3=77;5¿=#7;!!£5-57;!!=5!#15¿¡75¡%%9;')¿¿-åë¹¹¿s'=5#57¿w5-95¿W5¿;'!;¿=¿?åë¿¿¿{!!-#1¿¿1-!#5¿37¿;'!;¿=¿?åë¿¿¿5¿37¿%5%! ¿=77¿- 5åë¿¿¿U-#1¿w5-95¿W5¿-#¿'=95¿=¿?§¿5#7¿?=559åëy½VQÚtÔi)ÓKªÚ4ª:úëåë"

I have checked the baud rate, stop bit and parity bit and all are correct on Tera term and the device manager. I have tried this on both a windows laptop and a Linux laptop and I am having the same result between them. I have updated the drivers of the FTDI cable. I have hooked up the FTDI cable to a USB2ANY from TI using UART and was seeing the same result as above of the data being wrong. I have tested it at different baud rates and the data that is sent is always received as the same wrong data. An example is 0x22 is always received as a "7" across different baud rates. I have tried connecting two FTDI cables together and they can accurately send and receive data at different baud rates. an example being "banana" will be received as "banana". I have tried using minicom, Putty and Tera Term and the results are always the same. Is this something to do with the decoding of the data received? What could be causing this issue?

\$\endgroup\$
  • \$\begingroup\$ have you tried every baud rate available? \$\endgroup\$ – jsotola Nov 6 '18 at 23:55
  • \$\begingroup\$ It sounds like you're not using the same encoding on both ends of the cable? \$\endgroup\$ – Hearth Nov 6 '18 at 23:55
  • 2
    \$\begingroup\$ Perhaps the FTDI cable uses "RS-232" levels, and the board is "TTL" levels (or vice versa). The "TTL" signal levels are inverted relative to RS-232. Mixing the two will result in garbage like you show. \$\endgroup\$ – Peter Bennett Nov 6 '18 at 23:58
  • \$\begingroup\$ I have not tried every baud rate but i have tried 4 different slower baud rates than i am using. \$\endgroup\$ – m-walker95 Nov 6 '18 at 23:59
  • \$\begingroup\$ "It sounds like you're not using the same encoding on both ends of the cable?" How do i change the encoding of the tera term of FTDI cable? \$\endgroup\$ – m-walker95 Nov 7 '18 at 0:00
1
\$\begingroup\$

The issue was that the FTDI cable uses RS-232 levels(-6V to +6V) and the board that I am trying to communicate with is using TTL levels(0 to +3.3V). The solution was to use a USB to TTL cable. Here is an example of one: https://www.adafruit.com/product/954

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.