1
\$\begingroup\$

I have a Radio Shack DMM (Cat #2200811). I'm trying to test a 100uf 16v electrolytic capacitor on the auto range capacitance setting. I tried it with a 30uf 160v cap. and it worked (measured as 29uf) so I assume the meter works. But with the 100uf cap. I keep getting readings that are all over, such as .198nf then jumping to 50uf then O.F. To do the test, I've stuck the cap. leads into a piece of cardboard and I hold the meter leads to it. I think I have the polarity correct. I've tried 2 of these caps. and gotten the same results. Do I just have 2 bad caps or am I doing something wrong?

\$\endgroup\$
1
\$\begingroup\$

I doubt you have bad caps. 100uF is a lot, the meter could just not have the resolution to read the amount of charge it's pumping into the cap. If you have a function generator handy you could measure the capacitance by applying an AC signal to the cap in series with a resistor and see where the voltage amplitude falls to 0.701 of the original value (which is your RC pole).

In terms of what's wrong with your meter, it might just be too large. Try testing on increments of larger caps going up from 30uF.

\$\endgroup\$
  • \$\begingroup\$ Note: given a sin input, the power falls by 50% at the pole frequency. The voltage drops by 1 - 1/sqrt(2) = 1 - 0.707, or voltage drops by 29%. Or phaseshift becomes 45 degrees. Again, this is with a sinusoidal input. \$\endgroup\$ – analogsystemsrf Dec 9 '18 at 13:47
  • \$\begingroup\$ You're right, my bad. \$\endgroup\$ – Michael E Dec 9 '18 at 17:50

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.