0
\$\begingroup\$

I have a DMX WiFi receiver powered by a 3.7V 650mA battery. Link to a similar product

When I don't connect an external power supply nothing starts (no LED, etc.) but when I start with the external power supply and then unplug it my receiver works on battery as it is supposed to (and for the specified amount of time so like 8 hours IIRC.)

My guess is that the battery doesn't deliver enough current at startup without the external power supply or maybe a capacitor on the microcontroller.

I included pictures if you guys want to see the PCB. (I disconnected the battery in the pictures.)

Front side Back side

\$\endgroup\$
8
  • \$\begingroup\$ ” I guess it's that the battery that doesn't deliver enough current at startup” Highly unlikely. Sounds more like a design issue. Do you have more than one? Do they all behave the same? \$\endgroup\$
    – winny
    Jun 2, 2021 at 9:10
  • 1
    \$\begingroup\$ I have 3 including this one, it's the only one with this problem. \$\endgroup\$
    – Mat
    Jun 2, 2021 at 9:29
  • \$\begingroup\$ Ok, that should be solvable. Do you have access to an oscilloscope? A bad capacitor comes to mind. \$\endgroup\$
    – winny
    Jun 2, 2021 at 9:38
  • \$\begingroup\$ yes what should i monitor ? \$\endgroup\$
    – Mat
    Jun 2, 2021 at 9:51
  • 2
    \$\begingroup\$ [Three units and only one of them has the problem] is rather important information. It belongs in the question. The more information you provide about your issue, the better others will be able to help. \$\endgroup\$
    – Bort
    Jun 2, 2021 at 12:11

1 Answer 1

0
\$\begingroup\$

The fact that only one out of three behaves this way makes me suspect that there is a defect in that one as opposed to a design problem. Your notion that the battery may not have enough power to make it ride though the inrush current (milliseconds) at startup could have been a possibility if there was some high load, say a motor, but only small signal electronics and that your battery lasts for hours once energized speaks against it.

However, the battery does not respond well to microsecond transients, pretty much regardless of type, that’s what capacitors are for and the hand-soldered 470 uF looks dodgy. Test that one first.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.