2
\$\begingroup\$

I recently bought this wifi module.

Connected it to my pc and set it up according to the example provided. Thinking that it was just plug and play(as advertised) I hooked it up to my Arduino Uno, turns out this was not as easy as I thought. I then tried to set it up according to the manual(found here), but I had no further success with this method.

On the wifi module, there are three leds. When led3 is blink, it's indicating that wifi link has been achieved. I can only get led3 to blink when using Auto Workmode when setting up the module. As far as I can tell, even though led3 is blinking, there is no actual connection to the module.

Is there some way I can confirm that the module is infact online? I have tried to ping it, but it returns "unreachable host" but that could be due to some config error on my side.

TL;DR: I can't get my wifi module to work, how can I check that it is online?

\$\endgroup\$
1
\$\begingroup\$

How you have tested the module with computer? Is it in transparent mode? If the module is working as transparent mode it will convert wifi data to UART on your Arduino or PC UART port that's why it is called plug & play.

there is inbuit webserver on the nodule you can connect it to the PC through UART, and check with the WiFi Software test it. This way you can get idea whether it is working or not. You can make it work as STA or AP using the same software. Give it a little try.

I am not able to download manual. can you share it here so I can read and let you know the solution of your problem?

\$\endgroup\$
  • \$\begingroup\$ While there's nothing especially wrong with a direct link to a RAR archive maybe there's a page that describes that software in some more detail? Just thinking a lot of people might hesitate to install software of unknown origin without knowing a little more about it, and I couldn't see much information within the archive itself identifying the publisher etc. \$\endgroup\$ – PeterJ Feb 4 '15 at 11:09
  • \$\begingroup\$ I have previously used this module with the same software link which I have posted. I don't know somehow I am not able to download. \$\endgroup\$ – user3535403 Feb 4 '15 at 12:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.