0
\$\begingroup\$

I am experiencing something very weird with the footprint manager. When I allocate and validate the footprint change of some component, the footpring manager ECO , I validate and execute and everything goes fine.

However later when I try to update the PCB the ECO tell me footprint is not found as if the footprin manager operation I made previously was useless.

When I edit manually each component one by one in the schematic it works properly. I have only this problem with the footpring manager, I don't understand why it doesn't work

Why the foot print manager is not taken in consideration ?

\$\endgroup\$
2
  • \$\begingroup\$ What version of Altium are you using? And what data source -- Vault, SVN DbLib etc? There's a known bug with AD15 (some versions) where this occurs with a given vault version -- I had to make ECOs like that in AD14, and then re-open in AD15 -- about par for the course for those guys. My co-worker updating to AD15.1 seemed to be OK. \$\endgroup\$ – Krunal Desai Apr 26 '16 at 6:10
  • \$\begingroup\$ I use AD 13.5.8 \$\endgroup\$ – chris Apr 26 '16 at 10:07
1
\$\begingroup\$

I've had issues like this myself, it had something to do with Altium forgetting to load the library, double check to see if the library you're updating from is still installed, I'd had the library open, I edited a part and then when I went to update the PCB it couldn't find the footprint, I checked and the library was no longer installed, re-adding the library fixed the issue. But it seems odd that you can update the schematic though.

\$\endgroup\$
8
  • \$\begingroup\$ in my case the footprint manager allow me to change the footpring, but after I ECO, validate and execute the change, then it come back at previous stage \$\endgroup\$ – chris Apr 28 '16 at 8:50
  • \$\begingroup\$ Altium might be pulling the component from it's source library whenever you ECO, that may be why it keeps reverting \$\endgroup\$ – Sam Apr 29 '16 at 7:16
  • \$\begingroup\$ how to solve this then ? \$\endgroup\$ – chris May 2 '16 at 6:51
  • \$\begingroup\$ can you edit the original library? That should make the change pretty permanent \$\endgroup\$ – Sam May 2 '16 at 6:52
  • \$\begingroup\$ The problem I have doesn't seems to come from library but for altium to poit to the library. When I use the footprint manager I success to point the footprint properly and to ECO the change, but then when I try to update the PCB the ECO is generated again and it indicates to me that the footprint is not mapped/pointed anymore to the library as if the work I have done trough the footprint manger woudl have been useless. I am a bit desperate \$\endgroup\$ – chris May 8 '16 at 11:46
0
\$\begingroup\$

I have the same thing on Altium 20! 2 parts right next to each other in the same int lib, sharing the same sch / pcb libs. Pushing 1 part to the pcbdoc no issues, pushing the other part to the pcbdoc throws 'footprint not found!'

Have deleted / re-pasted / renamed pcb footprint object, sch object, recompiled the intlib, etc... trying to fix the library links. Nothing!! The part in my schdoc even shows the correct footprint model, but it can't push to the pcbdoc! Completely crazy...

Edit:

Ok I found the issue but not the root cause. For that particular component that could not push to pcb, I dug into the 'item manager' list from the tools menu in sch editor. That component somehow did not know the library it came from even though i kept deleting it and re-placing from the existing library. The 'update from libraries' link was broken too, even though I had just placed it from that install library. Maybe the project had cached a broken library link from somewhere else? I don't know I never found exactly why it happened. But! There is an option in 'item manager' to select the library / component. Once I did that the links were restored. Very vague, it took me probably 6 hrs total to work this one out, hope it saves somebody some time...

\$\endgroup\$
0
0
\$\begingroup\$

I fiddled with this for a day, then discovered that I if I went into the footprint manager and added the foot print there it worked.

In the footprint manager

I clicked on the part in the component list.

I then clicked 'Add' in the View and Edit Footprints area.

I then added the footprint

I then clicked on 'Accept Changes (Create ECO)

And I was off and running

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.