0
\$\begingroup\$

I fried a few MC34063 on the breadboard this evening.... was trying to make a 10V to -15V inverter to supply 30mA. It was working fine. However, the chips and inductor suddenly became hot when toggling the input power a few times. About 0.8A was flowing through the inductor when the chip failed. I thought the inductor core saturated, but simulations are also giving the same result if I lower the switching current. A similar circuit is below (actually I used 1mH 3.5Ohm inductor and Rsc=0.63Ohm (1Ohm turned out to be actualy 0.63Ohm)). The circuit below works fine if R3=1Ohm, but becomes weird if R3=2Ohm. Current flows into Vdd and out through Isns in the simulation (have not checked this in the failed parts). (Also, my timing cap was 1nF, not 330pF, it was running at about 33KHz, but oscilloscope showed gaps between clusters of square waves).

enter image description here

enter image description here

I checked with and without load on the breadboard, as well as simulation. Same results... and a pile of black chips (It took me a while to figure out). The inductor is fine, even after heating a bit each time.

So, what's going on? I know that MC34063 is an old design and all that, but this is like walking on eggshells. Everything works... till some kid toggles the power switch a few times...

edit: Schottky diode orientation is fine. Here is the figure from datasheet, for reference enter image description here

I agree with all comments about the breadboard. But, can anyone explain why the simulation fails if I decrease the current by increasing Rsc, or if I decrease the inductor value? I suspect the same thing happened on the breadboard. The inductance decreased enough so the darlington continued to conduct. Why did the current sense not work, even in simulation?

edit: I simulated while ramping up the voltage from 2 to 5 to 10V, every 10ms, and this one seems to simulate fine without the inductor current going up and locking (all other values same as the first schematic). May be the input cap is part of the design. Although, I did manage to fry one chip when switching off power to the circuit, can't figure out how that could have happened. I'll put in the input cap and try to fry another chip.

enter image description here

edit: I'm accepting analogsystemsfr's answer for pointing me towards capacitors. Initially I had a 330uF 25V on the output. I replaced it with 100uF 25V and added an input cap 100uF 25V as per the datasheet (100uF). All Capacitors were old but had tested OK on LCR meter before use. Both 100uF started heating up today, and I checked all three caps after that. All three caps had gone bad (but inductor and chip had not heated, and I was still getting my -15V output, althout very slowly after switch on). Replaced input and output caps with new 100uF 50V, and then input with 1000uF 50V. All are working fine with no heating, and tested OK after use. I toggled the power button maybe 40-50 times, and the chip did not fry. So I guess it was the capacitor. I still have no idea why it went bad. I have -15V across the caps, so it should have been fine, unless my input 10V got added to it somehow and became 25V across the caps during switching. Repetitive 25V across an old 25V cap may have damaged it... is my best guess now. And that shorted cap possibly led to chip failure. [My LCR meter shows two of the failed caps as a pair of opposing diodes with Vf of ~3V, the third one shows missing part (so failed open). None of the caps bulged or smoked.]

\$\endgroup\$
  • 2
    \$\begingroup\$ Breadboard + switching regulator = likliehood of failures \$\endgroup\$ – Andy aka Mar 4 '18 at 21:23
  • \$\begingroup\$ If you wanted a -15 volt output then your Schottky diode is reversed. Also, read the comment by Andy aka. \$\endgroup\$ – Sparky256 Mar 4 '18 at 23:31
  • \$\begingroup\$ What's the current capability of that inductor? \$\endgroup\$ – Chupacabras Mar 7 '18 at 20:13
  • \$\begingroup\$ I have no idea. It's a tiny cylindrical black one with two leads sticking out from one side, wrapped in heat shrink. It heats up a lot with 800mA DC, but working fine and cool at 300-400mA 30-130KHz. Since the entire circuit is working fine now, it is not an inductor issue (both core material and wire gauge are OK). I've only tried with the 1mH one, although simulations (with load) suggest even 330uH should be fine. My working circuit has 330pF timing cap and 1Ohm Rsc, runs at 130KHz till voltage is achieved, and then drops to 75KHz. 1KOhm 1W load resistor at -15V. \$\endgroup\$ – Indraneel Mar 8 '18 at 12:43
1
\$\begingroup\$

Your schematic shows no input capacitors. What are you using there?

And you have a "breadboard" with what parasitic inductances? Post a photo?

Between inductances and capacitances, you have many opportunities for ringing.

! amp switched in 10 nanoSeconds into 100 nanoHenries (4" of wire) will generate (wait for it)

V = L * dI/dT

V = 100nanHenry * 1 amp / 10 nanoSeconds = 10 volts

\$\endgroup\$
  • \$\begingroup\$ hmmm... no input caps, are they always required? Power supply is lm317 based and seems to be able to deliver 10V with 1mV ripple at 500mA, but have not checked with switching supply power draw. Breadboard circuit does not look good, although mostly short wires. But what about the simulation? Why does that fail too? \$\endgroup\$ – Indraneel Mar 4 '18 at 21:45
  • 1
    \$\begingroup\$ @Indraneel, yes, input caps on switching regulators are major part of functionality. Placement of the caps in closest proximity to the switcher is of fundamental importance. \$\endgroup\$ – Ale..chenski Mar 4 '18 at 23:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.