0
\$\begingroup\$

I'm working on a little 3D printed robot (Otto DIY) with an ESP8266 and four servos, and I need to feed it with batteries.

As a first thought, I considered some 18650 cells I had lying around, with a TP4056 charger and an MT3608 step up for powering everything. It didn't work, the ESP turned on but the servos didn't move. I tried everything but I had no luck, so I kept testing the robot with a 5V 1A Samsung charger. Then, a new idea came to my mind. I had a 5V 2A TP-Link power bank. Because of the size, I couldn't use it, but it powered everything perfectly. I found a much smaller and more suitable 5V 1A power bank (oh, just like the Samsung charger that worked just fine), but it didn't. It did just the same as the 18650 cells with the step up.

As I have little knowledge of electronics, I no longer understand the problem. The charger and the power bank are the same voltage and current, so why do they work differently? And most importantly, which is the best way to power this robot having in mind these details? It can't be too big or heavy; this little robot falls easily.

\$\endgroup\$
5
  • \$\begingroup\$ " I tried everything but I had no luck," tells us nothing at all about what you tried. Your imagination and mine may be quite different. So. It would help if you'd use the schematic editor (learn to use it, no matter how long that takes) and draw out from you what you have tried to connect and how you connected them up. If it takes you an hour or more, that's fine. It will save us more than that trying to draw out what you are doing and how. What servos are you using? How do you imagine they "work?" What software are you using to drive them, and how? Etc. You need to write A LOT. \$\endgroup\$ – jonk Oct 19 '18 at 19:18
  • \$\begingroup\$ The charger and the power bank might both claim to be 1A, but perhaps you're drawing close to or just above that 1A limit. In that case, maybe the charger can handle it (e.g., 1A was a conservative spec) while the 1A power bank cannot. \$\endgroup\$ – mith Oct 19 '18 at 19:20
  • \$\begingroup\$ The servos draw power dependent on size and load. With 4 servos you are probably well beyond a 1A rated supply and it may shutdown. The 18650 with a step up should work providing your step up converter handles the required current. \$\endgroup\$ – Jack Creasey Oct 19 '18 at 19:24
  • \$\begingroup\$ @JackCreasey the step up is an MT3608, which claims a max output current of 2A, but not working either. The voltage drops from 5V to 2.4V and the servos move just a bit, tickling a lot. When the servos stop, I get 5V again. I need a reliable and lightweight power source for this robot, and I don't know what to do. \$\endgroup\$ – Luciano Marti Oct 19 '18 at 19:38
  • \$\begingroup\$ @LucianoMarti Your servos are in all probability rated to 7V so you should increase the voltage supplied to them. You can also increase the output capacitance of you supplies to better provide high pulse currents. \$\endgroup\$ – Jack Creasey Oct 20 '18 at 15:57
1
\$\begingroup\$

The charger and the powerbank are not the same. They have the same rated outputs. Their actual voltage will vary, and the actual maximum current may be greater than what is specified.

It is also possible that the ratings for one or both of them are simply lies and they can't provide nearly as much current, or the output voltage isn't even close to 5V.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.