0
\$\begingroup\$

I can't read the chip ID of the ATMega16m1 MCU using a AVRISP mkII programmer.

The ISP pins are connected directly to the MCU, the reset line has a 10k pullup to Vcc (3.3V).

When measuring the ISP lines using a oscilloscope (see below), I saw that the the MISO line is stuck at ~1.68V which isn't right I believe. When I connect the programmer to a Arduino nano clone it works properly.

Does anyone have a clue what might be wrong?

AVR ISP measurement

\$\endgroup\$
  • 2
    \$\begingroup\$ What else is connected to the MCU? Consider providing a schematic. Have you tried programming the MCU without anything else connected? \$\endgroup\$ – JYelton May 28 at 20:54
  • 2
    \$\begingroup\$ Debugging questions need to be documented clearly with all the details of your setup. It's difficult enough to debug these things on a bench, without all information in the question it's like doing it blindfolded. \$\endgroup\$ – Voltage Spike May 29 at 19:42
  • \$\begingroup\$ @JYelton: issue is solved, next question I'll post a schemetic :) \$\endgroup\$ – Reinder Jun 5 at 18:16
  • \$\begingroup\$ Thanks for posting the details of your resolution. It may help someone else with the same or similar issue! \$\endgroup\$ – JYelton Jun 5 at 19:55
2
\$\begingroup\$

The issue is solved :)

I'd connected the programmer to the CLK/MISO/MOSI pins, but for the ATmega16m1 the ISP has to be done using CLK_A/MISO_A/MOSI_A.

\$\endgroup\$

Not the answer you're looking for? Browse other questions tagged or ask your own question.