0
\$\begingroup\$

I have an LED light bar powered by 6 AA batteries connected in series. There is also an RF control unit to turn the light on/off. The light eats through the batteries rather quickly thus I decided to experiment attaching a DC adapter to the light.

Due to the way the batteries are connected, I assumed that the light takes 9V to power, so to test my theory I grabbed a used 9V cell and it worked perfectly - even responds to the RF remote.

I then grabbed several DC adapters that output 9V with varying current and then began testing to see which one will work. First I tried one with 200mA and the lights turn on, but does not respond to the remote control. I then upped the current to 300mA with same result, but when I tried it with 600mA I heard the dreadful "buzz" as soon as I connected the circuit (did not even turn on the switch). As expected, I fried the RF receiver module in the light - yet the light still works. Even going back to the 9V battery does not allow the light to be operated by the RF remote.

So now I'm trying to find out what happened. If I have the voltage correct, shouldn't the worse that could happen is under-powering the light due to insufficient current? I'm assuming that even if I increased the current, there shouldn't be a problem since the resistors in the circuit should be limiting the current so there shouldn't be a risk of burning something out. The only thing I can come up with is that the adapter was putting out way more than 9V to fry the RF receiver circuit. Are there other possibilities about what could've went wrong?

\$\endgroup\$
  • \$\begingroup\$ You should have verified Vdc and AC ripple before trying/frying your RF RX. If regulated you could have used rechargeable alkaline with 200mA charger \$\endgroup\$ – Tony Stewart Sunnyskyguy EE75 Jan 13 at 18:12
  • \$\begingroup\$ @TonyStewartSunnyskyguyEE75 Yeah, looks like I was unknowingly dealing with an unregulated adapter. I should've check the current draw with the battery to get a full picture of the circuit before proceeding. \$\endgroup\$ – Dave H. Jan 13 at 20:33
  • \$\begingroup\$ "(did not even turn on the switch)" - assuming this is true, a simple power switch should have prevented any voltage getting to the RF module. So perhaps the circuit isn't that simple. Before going any further you should trace it out to see exactly where the power is going and how it is controlled. \$\endgroup\$ – Bruce Abbott Jan 13 at 20:37
  • \$\begingroup\$ You have a point. I can't be certain if I left the switch in the OFF state or RF state (they're OFF/ON/RF). Regardless, RF module will still get fried as soon as its circuit is closed in my setup. \$\endgroup\$ – Dave H. Jan 13 at 20:46
  • \$\begingroup\$ No load circuit was active and Voc exceed Vce rating \$\endgroup\$ – Tony Stewart Sunnyskyguy EE75 Jan 14 at 0:45
2
\$\begingroup\$

Possible reasons:

  • Many of those adapters are unregulated which means it might give 9 V when fully loaded but a higher voltage when lightly loaded.
  • You used an AC adapter. The alternating current alternates the polarity and that or may have caused damage.
  • You used one with polarity reversed. Check the label. Normally they are centre-pin positive.
  • You accidentally reversed the polarity.
|improve this answer|||||
\$\endgroup\$
  • \$\begingroup\$ Thanks. The first reason is the most probable explanation since I've triple-checked the output of the adapters with the multimeter to make sure they're DC and have the correct polarity. \$\endgroup\$ – Dave H. Jan 13 at 20:31
  • \$\begingroup\$ @DaveH. You used a multimeter to make sure they were dc and verified polarity but you didn't look at the voltage?? \$\endgroup\$ – Elliot Alderson Jan 13 at 21:38
  • \$\begingroup\$ Yes, I checked the voltage to be "around" 9V, a bit higher due to no load. Didn't quite associate the difference with current draw until I learn about the unregulated adapter. \$\endgroup\$ – Dave H. Jan 13 at 21:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.