2
\$\begingroup\$

When I perform the "electrical rule check" in KiCAD I get errors at my GND-Symbols.
pin connected to other pins but not driven by any pin

After googling I was presented the solution of going to a "pin property" menu.
Unfortunatelly I don't know how to get to that menu.
I only have the "property" menu of the symbol and I cannot set the "power property" there.

I tried using the "power flag" symbol and the "GND_PWR" symbol but that also produces similar errors.

GND problem

\$\endgroup\$
0

1 Answer 1

1
\$\begingroup\$

I solved the problem by adding another GND-symbol that is only connected to a PWR_FLAG-symbol separately from the circuit.

Solution

\$\endgroup\$
2
  • 2
    \$\begingroup\$ The power flag will also work if it's connected to the GND net anywhere, it doesn't have to be separate. \$\endgroup\$
    – jfowkes
    Dec 25, 2021 at 14:27
  • \$\begingroup\$ @jfowkes You are right but I found out that this only works if the power flag is very close to the GND symbol otherwise it seems to get connected to the wire or the next symbol. \$\endgroup\$ Dec 25, 2021 at 15:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.