3
\$\begingroup\$

While trying to simulate/run an LTSpice file with this Analog Devices component I have been given the following error and no simulation occurs:

"Could not open library file UniversalOpamps2.sub"...

The picture below is just an example of the error message with the problematic component. I have a different circuit containing this component with all of the connections but it is for an assignment so I can not share.

What I have tried:

  • Looking at other forums, I tried to include a spice directive of: .lib opampsuniversal2.sub but this did not help.
  • I ran a different file that didn't have this component and it worked perfectly.

Any ideas would be great, thankyou.

LTSpice Error: Screenshot

\$\endgroup\$
2
  • \$\begingroup\$ The library is not installed or is in the wrong directory. \$\endgroup\$
    – RussellH
    Oct 19, 2022 at 2:23
  • 3
    \$\begingroup\$ Interesting. I think we saw this issue come up recently. See Stu's comment -- it may apply. \$\endgroup\$
    – jonk
    Oct 19, 2022 at 4:04

3 Answers 3

4
\$\begingroup\$

Back in December 2021, LTspice changed how its UniversalOpamps worked. They created new symbols for each "level", and each with its own corresponding .lib file that is referenced. The problem is that they no longer include the UniversalOpamps2.sub file anymore with any new LTspice installation. This breaks any subcircuit which relies on this file being present. I knew this broke several user-created models, but it sounds like Analog Devices' own ADN8834.sub references the same deprecated UniversalOpamps2.sub. This looks to be an error on their part, and I don't know how many other of their proprietary models have the same issue. Unfortunately, we can't simply go into ADN8834.sub and tweak it to use one of the new UniversalOpampX models instead because it is a proprietary encrypted .sub file. Therefore, I would email "[email protected]" to inform them of the issue so they can fix it in a future release.


In the meantime, I would suggest downloading and installing LTspiceIV which can be found on the main LTspice download page under the link titled "Download for Windows XP (End of Support)". After installation, you can navigate to (assuming C: drive) C:\Program Files (x86)\LTC\LTspiceIV\lib\sub and find UniversalOpamps2.sub. Copy this file to C:\Users\YOUR_USER_NAME\Documents\LTspiceXVII\lib\sub and launch LTspiceXVII. Try running the ADN8834 simulation again and it should work now. You can also uninstall LTspiceIV after you successfully copied the UniversalOpamps2.sub file over. One thing to note is that your file associations will be messed up by doing all this, so you can launch the LTspiceXVII installer again (same download page as above, click "Download for Windows 7, 8, and 10") and it will give you the option to overwrite your existing installation. This will also repair the file associations, but you should do a [MenuBar->Tools->Sync Release] within LTspiceXVII so you can bring everything back up to date.

\$\endgroup\$
2
  • 1
    \$\begingroup\$ Wow thank you so much for such a helpful answer! Really appreciate it :) \$\endgroup\$ Oct 20, 2022 at 3:48
  • \$\begingroup\$ For what it's worth, I emailed [email protected] to inform them of the issue and the easiest way to fix it. \$\endgroup\$
    – Ste Kulov
    Oct 21, 2022 at 14:20
0
\$\begingroup\$

Solved recently: Interestingly, I originally added this component by pressing F2 (components) and then typing in the component.

The way I accidentally got it working was by going onto the Analog devices website and downloading their “example” file of this component of how it works. Once downloaded it simulated perfectly, and from there I could edit it to my needs and run the simulation with no problems.

\$\endgroup\$
1
  • \$\begingroup\$ Can you give a link to what you downloaded? I'm curious to know what specifically resolved it. \$\endgroup\$
    – Ste Kulov
    Oct 21, 2022 at 14:08
0
\$\begingroup\$

Go to https://github.com/evenator/LTSpice-Libraries/blob/master/sub/UniversalOpamps2.sub, download the UniversalOpamps2.sub file and paste it in your ...\LTspiceXVII\lib\sub folder.

Run the simulation; it should work.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.