I've got a design in Altium and while routing, I moved a few resistors. They somehow accidentally got deleted and wouldn't undelete. I brought them back with an ECO, and placed them where I want them. Now, I have connection stringers going to their old location, and can't seem to get rid of them. Anyone else come across this?PCB

Edit: Design rule check does not fix this.

  • \$\begingroup\$ I have had this in the past; I seem to recall that running a design rules check from within the PCB environment fixed it. \$\endgroup\$ Aug 30, 2019 at 14:44
  • \$\begingroup\$ @PeterSmith That did not work - tried already. \$\endgroup\$ Aug 30, 2019 at 14:49
  • \$\begingroup\$ Another reason that this can happen is that if there is a tiny piece of copper assigned (assuming you had routed them previously) which you will need to significantly zoom in on to actually see, it retains the net ID. \$\endgroup\$ Aug 30, 2019 at 14:50
  • \$\begingroup\$ @PeterSmith - had the same thought, tried that too. Nothing there. Selected the whole area and deleted it... Still persists. \$\endgroup\$ Aug 30, 2019 at 14:50
  • \$\begingroup\$ Are you sure you have all layers turned on? \$\endgroup\$
    – Axis
    Aug 30, 2019 at 15:31

1 Answer 1


Found the problem. Ran the command Design > Clean Net List, then Tools > Reset Error Markers - that cleared up the problem.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.