5
\$\begingroup\$

I am doing ground pours on both the top and bottom side of a two-sided board. The top side fill seems to work fine, but the pour on the bottom layer is leaving a bunch of odd shaped blank areas (see image on the left). I haven't routed any traces yet, so the bottom, which has no components, should be a solid blue.

enter image description here

The image on the right has both the top and bottom layers turned on. You can see the slightly darker red areas, that correspond to the blank areas on the bottom. Note these areas don't correspond to any features on the top layer, so it is not a matter of keep out or restrict areas.

I am using Eagle 7.5.0

Anyone know what is causing this?

\$\endgroup\$
  • 1
    \$\begingroup\$ It really looks to me like this design was "cloned" from another design, and that there's something left over on a layer that you aren't looking at that didn't get cleared out and is affecting the pour. Try turning on ALL of the layers and see if anything shows up. \$\endgroup\$ – Dave Tweed Jun 26 '16 at 11:13
  • \$\begingroup\$ @DaveTweed Actually this was done from scratch as a two-layer board. But I followed your advice, and went into DRC and enabled all layers 1 through 16, and in the Layers tool enabled 2-15 and disabled 1 and 16. All I got was a blank board. \$\endgroup\$ – tcrosley Jun 26 '16 at 11:19
  • \$\begingroup\$ That's not what I meant. I meant turn on the visibility of ALL of the control layers in the editor. It seems that there's something on a layer you don't normally look at that's creating an issue. \$\endgroup\$ – Dave Tweed Jun 26 '16 at 11:24
  • 2
    \$\begingroup\$ You're still not understanding my comment (which Olin has now expanded on). I'm not talking about layers 1-16 (the copper layers). I'm talking about all of the layers >16. \$\endgroup\$ – Dave Tweed Jun 26 '16 at 11:44
  • 1
    \$\begingroup\$ @DaveTweed Yes, I did misunderstand. Sorry. Olin's command string revealed the problem, which is something really weird on the bRestrict layer. If I'd followed your instructions correctly, I would have seen it too. \$\endgroup\$ – tcrosley Jun 26 '16 at 11:51
5
\$\begingroup\$

This really looks like you have something in other layers that is preventing the polygon algorithm from filling the entire area. Obvious suspects are bRestrict and a messed up outlines layer.

The way to find this is to turn on all layers. This is done with DISP ALL, if I remember right. That will show a bunch of superfluous stuff, but it shouldn't be hard to look for edges where there should be none. I'd start with DISP NONE BOT BREST OUT first and examine it carefully.

\$\endgroup\$
  • \$\begingroup\$ Thanks, that command string did the trick. I've got some kind of squarish thing in the bRestrict layer, half overlaying my circular board, and half outside it. It doesn't look like anything I recognize, now I just have to get rid of it somehow. Thanks. \$\endgroup\$ – tcrosley Jun 26 '16 at 11:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.