1
\$\begingroup\$

It's easier to place the PCB near the origin when using a pen plotter to draw it.

However, when I plot a mirrored PCB with pcbnew, it also changes the PCB position (it mirrors the whole page).

So, in order to get my PCB near the origin, I have to place it at the right bottom corner. This solution doesn't seem to be the standard way of doing that, because the PCB needs to overlap the page borders, as seen in the screenshot below.

PCB placed at bottom right corner

I also tried to flip my board over and place it at the origin, then plotting it without mirroring. As seen in the picture below, that's not the best solution either. I can't figure out where exactly is the origin and the PCB again needs to overlap the page borders.

Fliped PCB near the origin

Inkscape doesn't seem understand some HPGL commands used by KiCad so I can't use it to fix the PCB position. EAGLE has an option to offset the PCB origin (the actual PCB left bottom corner). Is there anything similar in KiCad?

\$\endgroup\$
1
\$\begingroup\$

Plot the front facing like so.

enter image description here

And the back-side like so

enter image description here

\$\endgroup\$
1
  • \$\begingroup\$ Thanks for replying and I'm sorry to only give you feedback this late. I remember trying to mirror the PCB this way. The problem is that this option mirrors the whole sheet and this results in changing the position of the PCB in the sheet. At that time I posted the same question in the KiCad forum and the solution given was to use a pcbnew template to show the actual origin of the cartesian coordinates of the sheet. Then flip the board using the editor and move it next to the now visible origin. I wish I could upvote your answer for helping out, but I don't have enough reputation. \$\endgroup\$ Jun 10 '21 at 14:20
1
\$\begingroup\$

The solution was given in the KiCad forum and is cited below:

I’d suggest some playing with the Worksheet Layout Editor:

enter image description here

The page settings give you control over the actual sheet size - grey border in editor area (in PCBnew, this setting is not stored with the worksheet design). The general options give you control over the origin of the drawing elements on that sheet - grey crosshair at top left border. Unfortunately, you can’t change the orientation of the coordinate system. I would try to create a custom sheet that fits/matches your plotter & use case (no need for anything but the border) and go from there.

enter image description here

You should be able to load the custom sheet design in PCBnew via that ‘Page Layout Description File’ field at the bottom of the page settings dialog (greyed out in the worksheet editor).

PS: if you’re able to run the OpenGL canvas [F11] instead of Legacy [F9] you should be able to see the grey sheet border in PCBnew. I can definitely only see it in OpenGL in Windows7, 64Bit with a nightly KiCAD from start of February.

Source: https://forum.kicad.info/t/mirror-pcb-only-not-the-whole-page-when-plotting-to-hpgl/6051

\$\endgroup\$
3
  • 1
    \$\begingroup\$ Please put the relevant information in this post, but cite it. It's fine to copy as long as you provide a link from where you got the information. If the link goes dead (which the often do) then the answer dies with it and it won't help anyone else \$\endgroup\$
    – Voltage Spike
    Jun 10 '21 at 18:12
  • \$\begingroup\$ @VoltageSpike I was reluctant to do this because if the author removes the content in the linked page, maybe he actually wants it to be removed from the web. But thinking twice you're right because it's better for the community as a whole and you must know better than me for sure. Thanks for your guidance. \$\endgroup\$ Jun 10 '21 at 18:38
  • 1
    \$\begingroup\$ Thanks for your help \$\endgroup\$
    – Voltage Spike
    Jun 10 '21 at 18:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.