1
\$\begingroup\$

There are some vias in my layout which I can't move after having selected them and holding left click. It displays a white cross after selection.

I have checked that those vias are not locked and they are not.

Any idea what I can do ?

enter image description here

\$\endgroup\$
2
  • 1
    \$\begingroup\$ Please post a screenshot of this "white cross" you refer to \$\endgroup\$ – DerStrom8 Sep 2 '16 at 13:26
  • \$\begingroup\$ Just delete it and re run the route. \$\endgroup\$ – Tyler Sep 3 '16 at 11:51
5
\$\begingroup\$

Generally when you are unable to drag components (and they're not locked) it's because clearance rules are holding them where they are. You can change the preferences in the DXP menu for moving components, but a less-permanent solution would be to press the "R" key while trying to drag the via. The "R" key switches the component placement mode between "Ignore Obstacles", "Push Obstacles", and "Avoid Obstacles". This should allow you to move the via regardless of the clearance rules provided you have the placement mode set to "Ignore Obstacles".

UPDATE

I just had the same problem today while routing a board for work. It is caused by clearance rules being broken by the traces attached to the via. What you must do is move the traces directly connected to the via first to make sure they are not breaking any clearance rules (or change the clearance rules, if possible), and then you should be able to move the via.

\$\endgroup\$
6
  • \$\begingroup\$ picture added in the topic. I will try the R key. \$\endgroup\$ – chris Sep 3 '16 at 2:34
  • \$\begingroup\$ @chris I don't think the R key will do anything for you. Have you tried the Move command? \$\endgroup\$ – Armandas Sep 3 '16 at 11:16
  • \$\begingroup\$ @Armandas I tried and indeed it didn't work \$\endgroup\$ – chris Sep 4 '16 at 6:48
  • \$\begingroup\$ Did you press "R" a few times while trying to drag the via? (You have to have a hold on the via and be actively trying to drag it when you press "R", and you have to hit the "R" key several times to get to the right mode) \$\endgroup\$ – DerStrom8 Sep 4 '16 at 19:48
  • \$\begingroup\$ @chris Please see my edit \$\endgroup\$ – DerStrom8 Sep 6 '16 at 12:20
3
\$\begingroup\$

In Altium, you cannot move multiple vias by just selecting them. To move them, use menu Edit->Move->Move Selection.

UPDATE

In the situations, such as shown in your screenshot, I typically select all the vias and their tracks and use Edit->Move->Move Selection By X, Y... command and then resize the tracks to the correct length.

\$\endgroup\$
0
\$\begingroup\$

in Design->Rules->Clearance-> set your clearance and set option with "Different Net" (altium 20.x)

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.